1

I'm using DD-WRT on my router (version DD-WRT v24-sp2 (12/11/14) mega). WAN is configured to have static IP and LAN is configured to have a DHCP server provide addresses/DNS, etc to clients. All of this works fine. However I am struggling to fix one specific thing. I have a DNS server running on my local network, at address 192.168.1.253 - and I want that DNS server to be set as the primary DNS for DHCP clients. I entered this DNS server as the local DNS server in the LAN settings:

enter image description here

enter image description here

Now when clients connect to the router, they do get an IP address from the DHCP and the local DNS server, however they also get the router itself as the primary DNS server and my local DNS as the secondary. All DNS queries go directly to the router, which then uses external DNS servers, thus making the local DNS totally useless.

How can I force DD-WRT to not send itself as a DNS server? Or, better yet, disable DNS server on the DD-WRT altogether?

0

D'oh! I totally missed the Services tab in the admin GUI. There I disabled dnsMasq - and everything is now hunky dory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.