0

Definitely not the first person to ask this, but I'm wondering how to troubleshoot this...

At the moment my wireless adapter on my Windows 7 PC is having issues connecting. My wireless adapter says it's Connected to the local WiFi network, but says it has "No Internet access". When I looked at my ipconfig, I saw a whole mess of "169.254.x.x" addresses. This looked familiar, so I tried the usual resetting of a few things in CMD:

ipconfig /flushdns

netsh int ip reset reset.log

netsh winsock reset catalog

shutdown /r

ipconfig /release

ipconfig /renew

shutdown /r

Then I tried setting a static IP that I knew wasn't taken on the local network.

No luck at any of the above stages. Plugged in my wired connection, and bam! Internet city. This issue used to plague me at my old house, and I would spend hours combing the Internet and finding no clue how to fix it.

Can somebody tell me something I'm missing?

  • Is DHCP activated on your WLAN Router? – marsh-wiggle Dec 25 '14 at 12:22
  • Yes, and it's assigning correctly for other laptops and phones in the house (192.168.1.215 for example). Just not my laptop, it's strange. – ZebGir Dec 25 '14 at 13:27
0

An 169.254.xx.xx suggests that your Wireless lan card was unable to obtain an IP Address from a DHCP server.

This can happen if no connection was made to a DHCP server (for example, no connection to the router because of a broken cable or faulty router) but given that you are on wireless and it says you are connected, this is not the case for you.

The second reason for this to happen, is that the DHCP server was not contacted during its route. Eg: you have a wifi accesspoint that relays the connection to the router, but the connection between the accesspoint and the router is not working properly. Wifi would still say you are connected, but the accesspoint itself can't hand out any IP addresses.

And thirdly (most likely) the DHCP server was contacted, but it could not hand out an IP address to you. This can have 2 causes.

  1. The DHCP server crashed, and your router needs to be restarted.
  2. The DHCP server reached all available IP addresses to hand out, and the DHCP scope needs to be increased.

So what you need to do is first follow the route your network travels. Look at the device that gives you wifi access. Does it still has a network?

Look at the router (or whatever provides you with IP Adresses). Is it still capable of giving out leases?


Also, just because other devices in the network get an IP Address, doesn't mean the DHCP still works. They could either still have their IP Address, and the lease just didn't expire yet, or they have a static IP Address.


If all of above is failing, the only reason I can think of that prevents your laptop from getting an IP Address is either something clientside, but a restart would rule that out (unless the wifi card is broken), or the MAC address is blocked on the router, which would've been done by someone.

  • Thank you so much for getting back to me! At the least, we're getting closer to that "full list" I wanted. Unfortunately, I don't think 1, 2, or 3, are the issue because: 1) I can see that I'm "Connected" to the network, but it just says "No Internet Access" 2) AP and router are one at the same at this house 3) DHCP scope is set at 100 (.100-.199) and router has been restarted All other laptops connected fine after restart and WPA2 password change MAC address is not blocked according to router webpage after factory reset I think the likely cause may be something with b/g/n selection – ZebGir Dec 26 '14 at 2:35
  • Could be that its a driver issue with your wireless card. Can you connect to another wireless device? (for example, set your phone to share its internet to a wifi hotspot and connect to it.) Also, try forgetting the wlan connecion and reconnect. Just because it says its connected doesn't mean the connection itself is good. – LPChip Dec 26 '14 at 12:43
  • you're a genius! I asked someone to set up their iPhone as a hotspot. Connecting to it brought up Network Diagnostics, and it complained that "DHCP is not enabled". Somewhat confusing, because in IPv4 settings on the adapter it was enabled before. Anyway, it connected. Then I connected to the WiFi. Again Network Diagnostics, but this time it complained that "The default gateway is not available". Fixed and connected again! Turned off the hotspot, and the connection went wonky for ~30 seconds. Then it came back. Gateway 192.168.1.1, IP address .109. Know what just happened? – ZebGir Dec 28 '14 at 4:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.