This is a desktop question using Win7x64 OS. I was doing a gfx (AMD) driver update after using the AMD Catalyst Install Manager to uninstall when asked to restart doing so all the usb ports stopped working. And I'm talking dead in the water dead. Tried rebooting to Safe Mode and the KB lit up briefly and even worked when making a choice, but when I choose an option be it safe mode or safe mode with networking or any other choice, after the windows files load and when it goes to the desktop the lights go off, the mouse doesn't respond nor do any thumb drives that are plugged in. I've tried the devices on my laptop and they all work fine.

Now get this my OS is on a SSD so.. I took and old HHD that had the OS on it plugged it up and bingo everything works so that more or less eliminates the MB being faulty and so now we're back to the software. I plugged my SSD along with the other disc drives and it now reads as H:/ dive (it was C:/) I was thinking if there was a way to reinstall the usb drivers to H:/ then boot to that it may work but microsoft (M$) in their articles state there's no need to download any drivers as their system already does that automatically, well I'm here to tell ya if they don't function when that drive is booted to, then how the heck are ya gonna get em to work? Like a fella said on another post they flat out don't respond, nothing, nada. So...in that drive I am unable to navigate at all period. Any ideas on how to put usb drivers on that drive so I can boot to it and go from there?

  • Do you tried to reboot using the Last Known Good Configuration? Ref: pcsupport.about.com/od/windows7/ss/… Hope this help. Let us know. – climenole Dec 26 '14 at 4:34
  • yes that was one of the first things I tried but it just went back to the desktop in the same condition. I checked the Windows files in both the old drive and the newer SSD drive and they are exactly the same .inf and PNF files in usbstor and Drivers in the Windows directory are the same also...was kinda hoping I'd see a missing file but they are all the same to a tee. – Sam Moss Dec 26 '14 at 4:57
  • wish I could get the ports to work THEN I could go into the Device Manager and do the uninstall deal but no dice. it's odd that both OS's show the exact same files yet one works and the other doesn't....puzzling. – Sam Moss Dec 26 '14 at 4:58
  • I can navigate in BIOS and Safe Mode but after that nada. I am really loath to do a fresh install because I have a lot of data on the SSD that I really want to keep and I can't transfer it... wait a minute maybe I can while using the HDD as my OS as I'm able to access the files in H:/ the only hang up I see is the registry will be gone and the programs won't respond. Still mulling this thing over as you can plainly tell. Any ideas on that would be welcome too. – Sam Moss Dec 26 '14 at 5:01
  • Did you try a power cycle, wait 30 seconds, then power on? – mdpc Dec 26 '14 at 6:17

I found by booting to another drive that works and listing the Windows usb files side by side in C:\ & H:\ I was able to find in C:\windows\drivers\usbfil was missing in H:\ copy>pasted it to H:\ rebooted to H:\ and bingo Windows uploaded the usb drivers and all is well in smallville again. The good news is now I've got Recovery Discs, Repair Discs and System Image but didn't have to use 'em by transferring what looked like missing files from one drive to the other. And..I have two bootable drives on the system. One HDD and one SSD. Thanks guys now on to that dang gfx update.

  • While it's working, make a disk image lest something else break. – DrMoishe Pippik Jul 5 '18 at 21:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.