0

I have the same problem as in here : AMD Graphics Drivers won't install properly

I have done all the steps that are instructed there, but when I am installing the drivers, it does this: http://gyazo.com/a1cb6f76a8fa9a6ab09cf882360ab82a it had an error installing the drivers, but that it found them. Also it says this: "Resource upload function in the cache has not been loaded MUI entry" I have the AMD radeon HD 6800 Series and I am trying to download the 14.12 update. No idea what my current version is, since I have thought before that it was correctly installing them.

  • I tried installing the earlier versions manually, and when installing 12.1, 12.2 and 12.4 it said that the devices driver software is up to date. But when trying to install anything newer, it encounters the problem. – Plshelp Dec 27 '14 at 21:15
  • Is this a graphics card you added or the AMD chipset incorporated on the motherboard? AMD drivers are a notorious problem for OEM hardware if you try to use the ones from the AMD web site. If the hardware is incorporated on the motherboard, download the driver from the computer manufacturer's web site. Don't worry about the version number. What is there will be appropriate for what's in your computer. – fixer1234 Dec 27 '14 at 21:36
  • I'm not sure what you mean by computer manufacturer, since my computer was build, but I did not build it myself. – Plshelp Dec 27 '14 at 21:54
  • 1st question: is there a separate AMD graphics card or is it built into the motherboard? If it is a separate card, this isn't relevant. If it's built into the motherboard, the drivers from the AMD web site may be a problem. 2nd question: where to get OEM drivers if the graphics are incorporated on the motherboard? The brand name manufacturers provide drivers for their equipment on their web site. You could start with the motherboard manufacturer. They may have drivers or could tell you if a brand name manufacturer uses the same motherboard. If no luck, try AMD tech support. – fixer1234 Dec 27 '14 at 22:06
0

This is a common problem with AMD drivers. My best advice is to restart your PC and try again, but use this tool if you didn't do it already. http://support.amd.com/en-us/download/auto-detect-tool

I hope this helped :D

  • Yeah I already used the auto-detect-tool thingy, will restart now and try again. – Plshelp Dec 27 '14 at 21:20
  • Did not help, still getting the same problem as before. – Plshelp Dec 27 '14 at 21:30
  • Well as I have said it's a common problem.with AMD. I would recommend googeling it. You will probably find a better answer there. – user2295443 Dec 27 '14 at 21:56
0

I got it guys! I just had to use driversweeper (http://www.guru3d.com/content-page/guru3d-driver-sweeper.html) and then reinstall the AMD catalyst, and it automaticly downloaded the latest drivers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.