0

I have a USB flash drive (FAT32 format) with the label "DT100G3" If I assign the drive to the letters "G" or "J" the label shows on Windows Explorer. However, if I assign the letter "F" to it, the label in Windows Explorer shows the default "Removable Disk" label. I've tried adding an autorun.inf file to the USB flash drive containing this text:

[Autorun]
label=DT100G3

However, the label still shows up as "Removable Disk" in Windows Explorer. If I open Windows's Computer Management and go to Storage > Disk Management I can see that the label is still "DT100G3" even though it doesn't show in Explorer.

What I have noticed is that in Disk Management, there is no drive letter next to my flash drive's label. The other drives do have a letter next to their label (e.g. My C drive has a "(C:)" next to its label).

I think the issue may be related to the fact that the letter "F" is the default letter assigned to any removable disk that I plug into my PC. Perhaps there is an entry in the Windows Registry that makes all drives that get assigned to "F" have the label "Removable Disk"?

Edit:
I reformatted the flash drive to NTFS, changed the drive letter to "G", then reformatted back to FAT32. Now even when using the letter "G" the label says "Removable Disk" in Explorer.

  • 1
    Sounds like maybe some caching issue going on. Check with the command prompt. If your USB drive is at F:, do vol f: to see the label. Do label f: to change the label. – user387876 Dec 27 '14 at 22:12
  • vol f: confirms that the label is in fact "DT100G3" I renamed it using CMD but it still shows as "Removable Disk" in Explorer. – Jorge Luque Dec 27 '14 at 22:18
  • 1
    CMD is correct. Explorer is not up to date with the new label. When this happens to me, a reboot typically fixes it. Worst case, you'll need to run sfc and a disk check to fix corrupted files. The registry location you ask about is: HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices and HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\DriveIcons\F\DefaultLabel – user387876 Dec 27 '14 at 23:05
  • Sounds like your flash drive is f'd, pun intended. – Moab Dec 28 '14 at 17:39
1

Sort of embarrassing but all that was needed was a restart. Thanks Tyler.

0

I think you are over thinking it.

To rename a USB, just go to explorer, plug your drive in, once the drive comes up, click it once, then again. The name will be highlighted for you to change. Type the new name and hit enter. Done!

  • I have tried this method already but it still shows up as "Removable Disk" in Explorer – Jorge Luque Dec 27 '14 at 22:20
  • This method works only when the drive letter is not "F" – Jorge Luque Dec 27 '14 at 22:23
  • 1
    Hmm. Interesting, have you tried to reformat it and give it a label throughout the wizard? – xR34P3Rx Dec 27 '14 at 22:23
  • yeah, I've reformatted it about 3 times now. Twice using Disk Management and once using EaseUS Partition Master. The label is there, it just doesn't show in Exploer – Jorge Luque Dec 27 '14 at 22:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.