0

Today I installed Windows 7 to a 1TB external USB hard drive. Everything worked fine, set up Windows and went to install drivers so I could connect to my LAN. My primary OS is Ubuntu, so I booted into Ubuntu, downloaded the proper drivers and moved them into a folder in my external drive. I then booted into my external drive and ran the executable to install the driver. I have tried all of the recommended drivers for my HP 700-215xt computer, all of which give me the following error: Your system does not meet the minimum requirements for this update. Update has been cancelled (9996). Here is a link to the HP support page that describes this error in greater detail and here is the list of supported LAN drivers for my computer.

My computer does meet the minimum requirements, which are simply Windows 7 and enough space to download. My friend and I tried doing this from his Toshiba laptop, installing Toshiba drivers and it worked fine. The OS on his Toshiba is Windows 7, while the OS on my HP is Ubuntu, which led us to believe that the problem has to do with Windows trying to install the drivers onto the hard drive rather than the external drive. Since my OS is Ubuntu, maybe the installation program thinks my OS is Ubuntu, since it is the OS on my hard drive? That is my only lead to the source of the problem. Whether I am correct or not, I have no solution. Could really use some help here!

0

After hours of troubleshooting we finally came to the root of the problem. The HP 700-215xt was not made for Windows 7 Ultimate, they ship with Professional Home, which I wiped when I installed Ubuntu. Not sure why, but apparently Windows 7 Ultimate requires different drivers than Windows 7 Home, and since HP ships with Home, the suggested drivers were not supported by Ultimate. Nightmare!

The solution was to find the actual hardware manufacturer and product of the wireless card in order to find the correct driver, and then install it. If you ever have this problem with Windows on an external drive, make sure you check to make sure that the computer you are running it on matches (or at one point, matched) the operating system on your external drive before searching for any drivers you may need.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.