5

i'm using vmware workstation 11. I can not bridge my network adapter. When i view Virtual network editor, there is not any bridged vmnet. I have NAT vmnet8 and host-only vmnet1. I added vmnet0 and changed Vmnet Information to Bridged and this error occured: Cannot change network to bridged: There are no un-bridged host network adapters. Reinstallation of vmware didn't solve the problem. Can you help me? Regards, Siavash

  • 1
    Look at the network editor. Does in the row External connection one of the vmnet has set Auto-bridging? If yes, click on it and chosse in bridged to one of your adapters. Every physical network card can be bridged only once. – marsh-wiggle Dec 29 '14 at 12:34
  • Is your NIC working fine and has updated drivers? – Scorpion99 Dec 29 '14 at 12:41
  • Dear boboes, No, First one is "-" and the second is NAT. there isn't any bridged vmnet. – sfallahdoost Dec 29 '14 at 12:42
  • Scorpion, my NIC is working in Host-only and NAT mode. – sfallahdoost Dec 29 '14 at 12:47
  • if u have kaspersky antivirus run vmware as Administrator – Zeroows Dec 27 '15 at 20:11
5

I have uninstalled kaspersky antivirus and problem solved!

| improve this answer | |
5

In my situation in Windows 10 running VMware Workstation 11.1, after restoring network setting to default(image 2) from Virtual Network Editor everything gets back to normal and I could get my WiFi internet shared.

  • My VM's network adapter setting is in NAT mode and no extra manual IP were configured for my VM and my Host

  • kindly note that before restoring to default all VMs should be turned off as suggested by the button itself if it is not

  • note that during resetting even VMnet0 with Bridged type which was not present become available too. maybe i have stopped some VmWare services related to this and restoring to default fix the related services too

Image 1:

VMWare Virtual Network Editor

Image 2:

enter image description here

| improve this answer | |
2

There is no need to uninstall the antivirus, simply go to your Physical network card properties, and uncheck the kaspersky anti-virus ndis 6 filter option.

Thats it....

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.