4

On my brothers keyboard a pipe character is being inserted whenever he uses the shift key. It is weird because the key itself still performs the normal function that shift performs and allows making capital letters however at the same time it inserts the pipe (|) character.

The keyboard layout is a normal Canada (English) layout with a US input. I am quite confused what may be the problem here?

This is on a Windows 8.1 machine.

9
  • "Canada (English)" Try switching it to the US layout. For some reason Microsoft thinks that every keyboard in canada has a french layout.
    – Arthur
    Commented Dec 29, 2014 at 18:53
  • @Arthur The French keyboard is disabled. This is the actual English layout. Commented Dec 29, 2014 at 18:55
  • I believe you. I've just had problems with any layouts that have "Canada" labeled on them.
    – Arthur
    Commented Dec 29, 2014 at 18:58
  • @Arthur well I switched to the US layout just to test and there is the same problem. It doesn't happen every time the shift key is pressed, maybe 50% of the time. Leads me to think it could be a hardware issue. Commented Dec 29, 2014 at 19:04
  • Ahhh, that's useful info. That may be the case. You may want to try another KB and see if that fixes it.
    – Arthur
    Commented Dec 29, 2014 at 19:17

3 Answers 3

2

Can confirm that this problem was only solved by replacing the keyboard.

The issue is intermittent printing of a pipe (|) character when pressing the Shift key. Moving the keyboard from a laptop running Windows 7 to an iMac produced a similar issue, but this time the Shift key intermittently printed the +/- symbol.

0

This happened to me today and since I'm using a chiclet-style keyboard, I cleaned it with compressed air and it was right as rain again! (or use a mini vacuum or blow air really hard from your mouth lol).

0

I was having this exact issue with a fairly new keyboard. The left Shift key was intermittently and fairly randomly inserting a pipe "|" character which makes for really bad time when typing passwords for example. I tried all sorts of solutions from reinstalling the hardware through Control Panel, updating drivers, changing layouts, etc. So I popped the key off and found a tiny hair in the contact. Removed it and it works fine. Hope that helps someone. I have yet to find another solution anywhere so far =)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .