63

I've created and run Hyper-V guests on this machine in the past. VT extensions are enabled in the BIOS; no changes made there. I've changed my boot device order recently.

How can I ensure that Hyper-V's host hypervisor is started on Windows startup?

When attempting to start a VM, the Hyper-V Manager error shows:

An error occurred while attempting to start the selected virtual machine(s).

Failed to restore virtual machine state.

Virtual machine 'Windows 10 Tech Preview' could not be started because the hypervisor is not running.

enter image description here

The Hyper-V Virtual Machine Management service is set to Automatic.

enter image description here

I've previously run bcdedit /set hypervisorlaunchtype auto as Administrator.

No other VM products like VMWare or Virtualbox is installed.

10
  • Check it in the services if it set to automatic at startup technet.microsoft.com/en-us/library/ee956894(v=ws.10).aspx
    – Scorpion99
    Dec 29, 2014 at 21:46
  • 1
    Have you got any other Hypervisors installed/running? ie: VirtualBox, or VMware? Dec 29, 2014 at 21:59
  • Following up what @Ƭᴇcʜιᴇ007 mentioned, different hypervisors on your system can seriously mess your system up and they can conflict with each other.
    – AStopher
    Dec 29, 2014 at 22:01
  • 2
    Because Hyper-V is a type 1 hypervisor, it has to be started before the Windows kernel, much like Xen. As such, bcdedit or similar tools are indeed your best bet. Fiddling with Windows Services, on the other hand, will solve nothing. Likewise, having VirtualBox or VMware installed won’t change anything. They will simply refuse to run when Hyper-V is enabled.
    – Daniel B
    Dec 29, 2014 at 22:35
  • 3
    Actually, bcdedit /set hypervisorlaunchtype auto solved that for me + cross checking bios settings for virtualization and updating bios firmware. Running bcdedit again will confirm if the settings has been set.
    – Norman
    Apr 13, 2016 at 18:26

8 Answers 8

75

I had exactly same problem and tips by Daniel B and Norman helped me: Running bcdedit alone revealed that hypervisorlaunchtype was indeed set to off so bcdedit /set hypervisorlaunchtype auto followed by a reboot did the trick.

I am reposting their comments as an answer to preserve them.

This was caused by (unsuccessful) attempt to run Android emulator from Android Studio.

5
  • 3
    Had same problem after cloning my system disk to new SSD by Samsung Data Migration utility. Using bcedit fixed the issue... Sep 23, 2017 at 8:14
  • Cause for me was cloning to a new drive as well. bcdedit "boot loader section" needs to say "hypervisorlaunchtype Auto".
    – Orangutech
    Mar 16, 2019 at 4:48
  • I had the same issue, but I had to restart the Host machine before it started working for me.
    – 3xGuy
    May 1, 2019 at 11:34
  • I had a problem with Hyper-V not starting on Windows 2012 Server after cloning the operating system disk (due to pending failure due to bad sectors). I suspect the low-level BCD settings didn't clone so the bcdedit worked for me too Jan 27, 2020 at 22:59
  • Worth noting that this may be the solution even if Windows Services shows that Hyper-V Virtual Machine Management is running. In my situation, bcdedit still needs to show "auto" and not "off"
    – Ethan C
    May 25, 2020 at 17:27
19

Since I've tried to install Docker for Windows, I found out that my CPU just can't run Hyper-V although I could install it.

This page explains that Windows 8 Hyper-V Client (and I think Windows 10 too) requires a SLAT-capable CPU to run. To check your CPU capabilities, use the Coreinfo utility (https://technet.microsoft.com/en-us/sysinternals/cc835722) with the option -v, the '-' character indicates that the feature is missing. Here you can see my CPU is missing every feature needed to run Hyper-V

Maybe your CPU lacks some features too, hope it helps !

1
6

For other users: I had exactly the same error.

Running bcdedit /set hypervisorlaunchtype auto did not help me.

Finally I figured out that I need to enable virtualization-related settings in BIOS first (I did not notice that from the question above initially).

1
  • 1
    virtualization-related settings can be found in advanced CPU settings in BIOS
    – que1326
    Nov 16, 2020 at 17:56
4

If it suddenly occurs starting 2022, this problem is due to bad patching.

KB5009624 is directly at fault and the issue should be solved if it is uninstalled.

This problem occurred for me for Windows 2012 R2 servers.

The updates at fault in question (depending on server version) are: KB5009624 (Windows Server 2012 R2), KB5009557 (Windows Server 2019) and KB5009555 (Windows Server 2022).

Other related patches that came in the same batch (may affect more or less the issue in the case of 2021 R2):

KB5009595

KB5008893

KB5008891

KB5008870

KB5008868

MS Tech Community link

1
  • Thanks! This fixed it for me.
    – NickG
    Jan 19 at 13:45
4

[Update] Microsoft released a fix for this (KB5010794), so install the fix rather than removing the update to avoid negative security implications.

Previous comment: I just encountered this problem. My hyper-v machines were all working perfectly and then the windows server updated overnight and none would start up the next day. The bcdedit did not help for me. It was caused by KB5009624 or KB500263. Removing both of these and then rebooting fixed my issue.

1
  • I just saw that KB5009624 was installed on our server today and HyperV stopped working. Removing this one fixed the issue. Thanks.
    – vmasanas
    Jan 13 at 11:56
0

I got this exact problem after changing a motherboard on a HyperV host computer

Enabling Intel Virtualisation technology in the BIOS fixed it

0

I had the very same error when using Macrium Reflect's viBoot with Hyper-V on Windows 11, but the other answers did not apply. We are not using Windows Server, bcdedit hypervisorlaunchtype was already set to auto, everything was working until we installed Virtualbox (after already disabling Hyper-V) and we had rebooted both the VM & the host OS.

We had previously used Virtualbox, but that had been uninstalled and the bcdedit was returned to normal (i.e., auto) so that we could return to Hyper-V.

The solution was a somewhat lengthy set of shut downs / boots:

  1. Disable Hyper-V via the Features Add / Remove panel.
  2. Shut down the PC.
  3. Boot the PC.
  4. Enable Hyper-V
  5. Shut down the PC.
  6. Boot the PC.

While Windows recommended restarting, for some reason that did not work for us even after a few hours of trying fixes & rebooting. The error message in Macrium noted that some BIOS option changes required a shutdown + fresh boot (and not a reboot), so we wondered if that applied to Hyper-V changes, too? We tried it and it worked.

Throughout all these procedures, hypervisorlaunchtype remained auto which is the most common solution I believe.

Tested on

  • Windows 11 Pro (22000.556)
  • Macrium Reflect v8.0.6635 viBoot w/ Hyper-V

With this, we were finally able to boot into a Windows XP 32-bit guest OS.

-3

Try Updating linux Kerner

Cheers

1
  • Given how often and major MS messes things up this is becoming closer and closer by each day passing.
    – Overmind
    Jan 19 at 7:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.