I've created and run Hyper-V guests on this machine in the past. VT extensions are enabled in the BIOS; no changes made there. I've changed my boot device order recently.

How can I ensure that Hyper-V's host hypervisor is started on Windows startup?

When attempting to start a VM, the Hyper-V Manager error shows:

An error occurred while attempting to start the selected virtual machine(s).

Failed to restore virtual machine state.

Virtual machine 'Windows 10 Tech Preview' could not be started because the hypervisor is not running.

enter image description here

The Hyper-V Virtual Machine Management service is set to Automatic.

enter image description here

I've previously run bcdedit /set hypervisorlaunchtype auto as Administrator.

No other VM products like VMWare or Virtualbox is installed.

  • Check it in the services if it set to automatic at startup technet.microsoft.com/en-us/library/ee956894(v=ws.10).aspx
    – Scorpion99
    Dec 29 '14 at 21:46
  • 1
    Have you got any other Hypervisors installed/running? ie: VirtualBox, or VMware? Dec 29 '14 at 21:59
  • Following up what @Ƭᴇcʜιᴇ007 mentioned, different hypervisors on your system can seriously mess your system up and they can conflict with each other.
    – AStopher
    Dec 29 '14 at 22:01
  • 2
    Because Hyper-V is a type 1 hypervisor, it has to be started before the Windows kernel, much like Xen. As such, bcdedit or similar tools are indeed your best bet. Fiddling with Windows Services, on the other hand, will solve nothing. Likewise, having VirtualBox or VMware installed won’t change anything. They will simply refuse to run when Hyper-V is enabled.
    – Daniel B
    Dec 29 '14 at 22:35
  • 3
    Actually, bcdedit /set hypervisorlaunchtype auto solved that for me + cross checking bios settings for virtualization and updating bios firmware. Running bcdedit again will confirm if the settings has been set.
    – Norman
    Apr 13 '16 at 18:26

I had exactly same problem and tips by Daniel B and Norman helped me: Running bcdedit alone revealed that hypervisorlaunchtype was indeed set to off so bcdedit /set hypervisorlaunchtype auto followed by a reboot did the trick.

I am reposting their comments as an answer to preserve them.

This was caused by (unsuccessful) attempt to run Android emulator from Android Studio.

  • 3
    Had same problem after cloning my system disk to new SSD by Samsung Data Migration utility. Using bcedit fixed the issue... Sep 23 '17 at 8:14
  • Cause for me was cloning to a new drive as well. bcdedit "boot loader section" needs to say "hypervisorlaunchtype Auto".
    – Orangutech
    Mar 16 '19 at 4:48
  • I had the same issue, but I had to restart the Host machine before it started working for me.
    – 3xGuy
    May 1 '19 at 11:34
  • I had a problem with Hyper-V not starting on Windows 2012 Server after cloning the operating system disk (due to pending failure due to bad sectors). I suspect the low-level BCD settings didn't clone so the bcdedit worked for me too Jan 27 '20 at 22:59
  • Worth noting that this may be the solution even if Windows Services shows that Hyper-V Virtual Machine Management is running. In my situation, bcdedit still needs to show "auto" and not "off"
    – Ethan C
    May 25 '20 at 17:27

Since I've tried to install Docker for Windows, I found out that my CPU just can't run Hyper-V although I could install it.

This page explains that Windows 8 Hyper-V Client (and I think Windows 10 too) requires a SLAT-capable CPU to run. To check your CPU capabilities, use the Coreinfo utility (https://technet.microsoft.com/en-us/sysinternals/cc835722) with the option -v, the '-' character indicates that the feature is missing. Here you can see my CPU is missing every feature needed to run Hyper-V

Maybe your CPU lacks some features too, hope it helps !


For other users: I had exactly the same error.

Running bcdedit /set hypervisorlaunchtype auto did not help me.

Finally I figured out that I need to enable virtualization-related settings in BIOS first (I did not notice that from the question above initially).

  • 1
    virtualization-related settings can be found in advanced CPU settings in BIOS
    – que1326
    Nov 16 '20 at 17:56

Try Updating linux Kerner


Not the answer you're looking for? Browse other questions tagged or ask your own question.