2

I'm working on Windows 8.1 Professional. The machine is currently configured "Private" in a place that should be "Public". In its docs, Microsoft refers to this as "Public Mode" and "Private Mode" (see the KB below). The machine is not part of a HomeGroup.

enter image description here

I want to change the type to "Public", but I'm having trouble locating information on it (is it really intended to be this difficult?). I can find stuff on turning sharing on/off, changing HomeGroups settings, etc (some of the links below). But nothing that simply states how to change the adaptor's setting from "Private" to "Public".

Note well: Sharing on/off does not equate to public/private. I tried it, and I can say for certain that's not it on Windows 8.1.

How does one change the adaptor's setting from "Private" to "Public"? Screen captures would be very helpful because little of what I am finding is actually matching what I see.


Similar issues and searches:


How to change from Public network to Private network (on Super User) says to delete the connection and start over. The problem is slightly different, and I'm hoping for something less destructive (it seems to be killing a fly with a cannon ball).


This is how maddening the problem is. I run through the Network Troubleshooter to try and get to a place to manually change things (as suggested in a number of hits on the web):

enter image description here

Ass soon as I click on "Explore Additional Options", it takes me to this useless screen:

enter image description here

  • 2
    superuser.com/questions/395606/… – maudam Dec 30 '14 at 0:20
  • @Maudam - I take that back. I think Huynh's answer solved the problem. But it did not appear solved until after I rebooted (I recall checking before the reboot, but did not see the switch from Private -> Public). So thank you. I cast the first duplicate close vote. – jww Dec 30 '14 at 1:00
5

You can do it by PowerShell:

Set-NetConnectionProfile -Name Network -NetworkCategory Public
3

For those who stumble upon this, I believe the answer was provided by Huynh in How do I set my wireless network to be private instead of public?.

I can only say "I believe" because it took a reboot to get the expected result. But the reboot followed a few turns of a few different knobs, so I can't say for certain.

Its really unfortunate that Microsoft made recovering from a simple typo so difficult.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.