2

I'm using Virtualbox on Windows 8 machine. My guest OS is Linux with Awesome WM. My problem is that my mod key is set to WIN. This causes problem with WIN + L, as it doesn't go to guest OS. It gets caught by Windows and causes computer to lock. Is there any way to fix this or overcome? I know two solutions:

  • disabling locking in windows - not an option for me
  • use different key bindings by exchanging:
    • WIN key - but it is hard to find different key that wouldn't clash with vim
    • L key - but this works well with other vim navigation keys

Do you know any better approach towards this?

0

To pass everything to VirtualBox, I make sure that in the bottom right corner of the VM window, it looks like a down arrow filled in green. The key to activate it is written next to it, like this

VirtualBox

As you can see, the arrow is black. Press the key that is outlined next to it (Control_R) to make it green and pass everything to VirtualBox.

  • It didn't worked. It doesn't matter whether this is black or green as in either case WIN + L results in screen lock – kkonrad Dec 30 '14 at 10:47
  • After reading forums.virtualbox.org/viewtopic.php?f=6&t=32265 , Try Host+L – EdG Dec 30 '14 at 10:57
  • also no luck with it - it just sends L – kkonrad Dec 30 '14 at 11:25
0

Do a one time disable of locking.

Write a program that does the following- Reenable locking from registry Lock computer Disable locking

Map this to your favorite hot key

There is an ahk that does that- on phone so can't find

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.