4

I'm now a full time user on Linux. Ubuntu did the job at the beginning but after several months of dealing with unity I thought of switching to KDE. After I got bored of KDE I switched to XFCE and then the problem arrived. If I boot up the PC and log in, internet is not available. eth0 is missing from lspci/ifconfig, only l0 appears. After a reboot, everything is ok. After searching and searching, I could not find any clue and thought that Ubuntu may be the fault, so I switched to Manjaro XFCE. Same thing is happening here, but the system is faster and it does not bother me to restart it before I log in.

I don't know if it is a hardware problem or a software bug regarding the network manager in Manjaro, but if I boot from a Live USB, everything is ok.

How can I solve this problem, so that my internet would work without rebooting?

0

1 Answer 1

6

I suspect three possibilities:

  • hardware failure (broken components or just unrealiable conections)
  • driver failure (dosn't handle some state correctly)
  • software failure (dosn't bring up interface because of some feature/bug)

Things to try (You may need to adjust/change commands used):

ifconfig -a
ifconfig eth0 up
dhclient eth0

You can also try reloading driver module using rmmod / modprobe.

EDIT:

Since previous attempts didn't help, I would suspect something hardware related (unreliable connection, fried component, etc). If reboot helps, problem may be related to power - You may try:

  • instead of reboot turn off PC completely (maybe even unplug from utility power), wait a few minutes and turn on it again;
  • try resetting machine before OS starts booting (turn on, wait until bootloader is displayed and reset);
  • try take-out and insert LAN card (if it is not integrated).

EDIT2:

From comments it is clear the problem is related to "TCS fast calibration failed" message during boot. A few things to try:

  • check cat /sys/devices/system/clocksource/clocksource0/available_clocksource - are contents different when internet is working and when it is not?
  • try adding kernel boot parameter clocksource=acpi_pm or clocksource=hpet (got idea fro this page)
  • check PSU for capacitor plague (MB already checked as per comments)
  • try removing LAN card - do You still see TSC error?
  • if it is an option - try installing some older Linux distribution to hard disk (not CD/USB boot) and see if it works better with LAN card.
  • try replacing PSU or LAN card, as these are components which most likely may be out-of-order.

From my experience, I would bet the source is PSU (had seen enough weird problems on similar hardware).

EDIT4:

Seems it is not PSU... If other options above fail, try capturing:

dmesg > boot.log

And check for differencies when LAN is working, and when it is not. You should see at least TSC error which You decsribed before, but there may be other differencies too:

diff bott_ok.log boot_fail.log

EDIT5:

From the comments it seams problem is related to PCI enumaration during cold-reset and hot-reset, identified using lspci while in GRUB loader (before Linux kernel loads). Things to try:

  • boot kernel using options like reset_devices, nobios, conf1, conf2 (just a few which got my attention, You can find many more in Documentation/kernel-parameters.txt, look for BIOS or PCI related options first);
  • sice machine loads successfully from USB, pluging in USB device while booting from HDD may trigger correct behaviour.

EDIT6:

Clear BIOS settings (reset, clear using jumper on MB, upgrade/rewrite). Try playing with "Reset configuration data", "PnP OS installed", PCI timings or similar BIOS sertings.

32
  • Tried those commands but nothing worked. My NIC is not even listed, but after reboot I got this in lspci: Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 11) .
    – crishu
    Dec 30, 2014 at 15:29
  • 1
    pastebin.com/zaT8uD6i - cold boot - no internet
    – crishu
    Dec 31, 2014 at 17:23
  • 1
    pastebin.com/Rx0dGbUt - after restart - internet working
    – crishu
    Dec 31, 2014 at 17:24
  • 1
    On cold boot, ethernet card is not available, but after a reboot, it is. So after all, it is a hardware problem...
    – crishu
    Jan 1, 2015 at 11:20
  • 1
    It works!!! I restored the BIOS default values, and when I booted up it said: "error: Expansion ROM not initialized for PCI Network Controller on MB". I remember the last time I got this error I modified the BIOS location, from Expansion ROM to TOP OF BASE MEMORY. Now I left it to Expansion ROM and disabled LAN REMOTE BOOT, and everything works! Thank you mate! Saved me a couple of bucks.
    – crishu
    Jan 2, 2015 at 12:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.