1

We have a Windows 8.1 installation on an HP 23-g009 AMD Quad core all-in-one computer. Two days ago, it got into an Automatic Repair Loop.

Auto Repair Error

We have done much research and have made many attempts to fix this, but have not yet found the way to fix it. A lot of other people have had these problems as the key error phrases show up in numerous forums, but we realized many of these solutions applied to Windows 7 or earlier and many refer to the older boot system rather than the newer UEFI boot system used on our system.

With Windows 8, there is a Windows Recovery Environment, which is a partition on the drive with tools to help you recover without needing to boot off a startup DVD. From the Recovery Environment, we can go into a Command Prompt with what seems to be full administrator rights, from where we have attempted fixes.

We have already done the following:

  1. Checked the Automatic Repair log file which says:

    Boot manager failed to find OS loader.
    Boot configuration data store repair. Result: failed. Error Code = 0x2

  2. Chkdsk c: /r - Which repaired a few file references but found no bad sectors

  3. Tried the standard boot recovery procedures (in various orders as written elsewhere)

    bootrec /fixmbr
    bootrec /fixboot
    bootrec /rebuildbcd
    bootsect /nt60 all /force /mbr

    These did not help. The bootrec /rebuildbcd line gives: "Total identified Windows installations: 0"

  4. Tried to repair the bootloader. See related superuser question.

    diskpart
    lst dsk
    select disk 1
    lst vol
    select volume 4 (This is our FAT32 partition)
    assign letter b:
    exit
    cd /d b:\efi\microsoft\boot
    bootrec /fixboot
    ren BCD BCD.bak
    bcdboot c:\windows\system32 /s b: /l en-us /f ALL

    The last line results in the message: "Failure when attempting to copy boot files"

  5. Tried to do a System Restore, but system restore said there were no restore points.

  6. Tried Running the system file checker:

    sfc /scannow

    That gives the message: "There is a system repair pending which requires reboot to complete". But a reboot does not change this.

The idea I have is to manually recreate the Boot Registry hive. I've seen illustrations on how to do this with instructions such as:

 attrib -h -s C:\boot\BCD  
 del C:\boot\BCD  
 bcdedit /createstore c:\boot\bcd.temp  
 bcdedit.exe /store c:\boot\bcd.temp /create {bootmgr} /d "Windows Boot Manager"  
 bcdedit.exe /import c:\boot\bcd.temp  
 bcdedit.exe /set {bootmgr} device partition=C:  
 bcdedit.exe /timeout 10  
 attrib -h -s C:\boot\bcd.temp  
 del c:\boot\bcd.temp  

However, it is not clear what this does and I'm not willing to experiment with it, especially since my bcd is not in that directory and my Windows Recovery Environment makes the files accessible without the need of the attrib statement.

There is a nice Superuser question: How can I repair or install startup repair/system recovery after BCD corruption? which tells about a Visual BCD Editor that seems to have a big learning curve, and I'm leery to try unless I have a clear guide on how to set up my BCD. I also don't know if it will run under the Windows Recovery Environment.

So my two main roadblocks to my fixing this seem to be:

  1. Bootrec is not recognizing my Windows installation on C drive. It says there are 0.
  2. Reconstructing my Boot Registry hive: b:\efi\microsoft\boot\BCD

These are probably related problems, and it might be that fixing one may easily solve the other.

The Windows 8.1 installation and all our user data is still safe and I can see it all from the command prompt. And it seems that I'm so close, but just can't get past those two roadblocks.

What will allow me to fix this without reinstalling Windows?

1

The fix we took was a real cop-out. We bailed and simply restored the system to initial state from the recovery disk. We did have a backup of the data that was only 2 weeks old so we didn't lose much, and still had access to the disk and copied over a few extra files we wanted prior to the restore.

The main point is we saw via Google how many people have had this problem. A lot! It looked like a simple fix, and we tried nearly everything.

The bottom line is we spent 3 days trying to solve this problem. That was probably 2 days too long, because it only took us a day to restore and load our backup data and reinstall our software. i.e. It's nice to figure out how to fix something if you can, but we were already starting to waste time and wanted our computer back.

I hope this helps someone.

0

UEFI boot is not using boot records. So forget about bootsect.exe, bootrec/fix... commands.

  1. boot from USB/DVD/CD
  2. map EFI System partition on HDD (if not already mapped)
  3. copy BCD (= BCD backup)
  4. delete BCD
  5. bcdboot command as already listed in your question.

If bcdboot command fails then some other file, not BCD, is the problem. So you have to delete \boot and \Microsoft folders (copy them for backup first) and try bcdboot command again.

To repair system files on Windows 8 and later the utility "dism.exe" can be used (network connection gives the ability to download system files from Windows update!):

Dism /Image:C:\offline /Cleanup-Image /RestoreHealth /Source:c:\test\mount\windows

Repair a Windows Image

Configure a Windows Repair Source

  • Thanks for the answer. Unfortunately the bcdboot still failed. We didn't mess around with the Windows system files as we really didn't feel that was the problem. The Bootrec definitely wasn't recognizing the Windows operating system. – lkessler Jan 5 '15 at 22:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.