0

I am using Imagemagick(6.4.3.6-7.18.x86_64) in SLES11 SP2

Using it like bellow..

import -window $wid $jpg

and getting this error

import: DelegateLibrarySupportNotBuiltIn `' (X11) @ error/import.c/ImportImageCommand/1303.

This LINK suggests to install the X11 `development package.

I search for the package(zypper se xorg-x11-devel) and it's available but when i try to install that getting this message..

zypper in xorg-x11-devel

Loading repository data...

Reading installed packages...

Resolving package dependencies...

Problem: nothing provides libuuid1 = 1.41.1 needed by libuuid-devel-1.41.1-13.9.x86_64

Solution 1: do not install xorg-x11-devel-7.4-8.18.x86_64

Solution 2: break libuuid-devel by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c): c

Checked for the libuuid1 package and this one is already installed on my system.

zypper info libuuid1

Loading repository data...

Reading installed packages...

Information for package libuuid1:

Repository: SUSE-Linux-Enterprise-Server-11-SP2 11.2.2-1.234

Name: libuuid1

Version: 2.19.1-6.29.3

Now what should be my next step, remove the current version(2.19.1-6.29.3) of libuuid1 and back to the mentioned older version libuuid1 = 1.41.1?

If i do so what problems i might face?

or any other idea/suggestion.

Thanks

0

Downloaded the libuuid-devel package from

http://suse.curingapneus.com.br/SLES-11-SP2-SDK-DVD-x86_64-GM-DVD1/suse/x86_64/

After installing this version (libuuid-devel-2.19.1-6.29.3.x86_64)

xorg-x11-devel package was installed.

Note:

libuuid is used by many things like udev, devmpper, etc so rolling it back probably not a best idea.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.