0

I'm running windows 7 Ultimate SP1 x64.

When I access the network tab from start I get a yellow banner saying Network discovery and File sharing are turned off. If I click to change it just reverts to the same message. When I turn Windows firewall off it works fine.

I have tried to turn the stuff on via windows firewall advanced settings, inbound rules, new rule and discovered Predefined was greyed out. After some research I deduced that the issue was the default key and all sub keys was missing from the registry node [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\SharedAccess\Defaults].

I am guessing possibly something to do with removing Symantec end point protection.

I successfully exported the key from another working machine with the same setup and imported to the non-working machine which populated the predefined rules correctly however now get an access denied error while attempting to install the rules.

Does anybody have any idea how or what I have to do to complete the fix?

1

I guess I found the solution on answers.microsoft.com

http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/network-discovery-and-file-sharing-wont-stay-on/a12402a4-2826-4a0e-9b5b-45918ce33ef2

Appears to be a corrupted firewall and in the answer thread I found

This Tool does it for you without requiring a working machine to export the file http://www.majorgeeks.com/mg/getmirror/tweaking_com_repair_windows_firewall,2.html

Downloaded the file tweaking.com - repair windows firewall v2.8.8 from the link above and ran it. Total Repair Time: 00:01:26 and now everything is working as it should be. Odd that I was getting access denied applying the rule but whatever this did it did fix the issue.

It would appear that I had partially fixed the issue by exporting the shred access default rules but still had some other problem. The tool I ran apparently would have reapplied the default rules also so maybe that it what fixed it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.