1

Basically NAT is being a huge pain in the ass for me because the tiny NAT table of my modem/router keeps filling up all the time and then I can't get any packets through for several minutes (this happens for example every time I ping a lot of servers).

Now, I only have one computer so I don't need NAT and I want to get rid of it. I have 1 public IP from my ISP.

I've done some research and it seems one way to do this is to have the modem act as a bridge and use Windows to establish a PPPoE connection. But one problem, PPPoE requires an username/password from the ISP. And I don't think my ISP even supports PPPoE since all the modems they hand out are configured to use IPoE (ENET ENCAP) that doesn't require any kind of credentials to make a connection.

I have tried to simply turn off NAT from my modem, but then my computer loses internet connection. I've done some research and apparently it is because I'm using my LAN IP to send packets to the ISP which then drops them (because my modem is no longer changing the source ip of the packets).

I've tried to send packets using my public IP as the source, but got no responses. Is my modem dropping the responses instead of broadcasting them to my computer in the LAN?

But anyway, my ultimate question is, is there any way to not use NAT and still have an internet connection? Only one computer, only one public IP. And if so, how

19
  • the usual workaround is to just reboot the router every so often. Dumbing the router down to pure modem mode would not require the next machine to provide PPPoE info, as the modem would still do that, but it would require another [better] router/firewall (which would still be doing NAT, only more efficiently), as a Windows workstation is really not equipped to do that well.
    – Tetsujin
    Dec 31 '14 at 16:34
  • All depends on the ISP, if they do DHCP then all you would have to do is plug your ethernet connection in from the ISP to the back of your machine and make sure you ethernet adapter is set to use DHCP. If it's PPPoE you must have configured the modem long ago with the username/login, also ISPs like to use MAC addresses of their modems to set lease reservations, you may need to duplicate the MAC address of the modem on your machine to get the DHCP request. Lots of different factors at play here.
    – Optichip
    Dec 31 '14 at 16:38
  • I really wouldn't recommend hanging a Win desktop straight onto the 'raw' internet. Win firewalls are not exactly industrial grade
    – Tetsujin
    Dec 31 '14 at 16:40
  • @Tetsujin You write "Dumbing the router down to pure modem mode would not require the next machine to provide PPPoE info, as the modem would still do that, " <----- Obviously it's not "pure modem" mode if it is doing PPPoE. I have a router-modem and when I put it in bridge mode, it doesn't do PPPoE.
    – barlop
    Dec 31 '14 at 17:02
  • Your research re PPPoE is spot on. You can go online without NAT and with a public IP given to your computer(not necessarily that secure but you can). I'm not that familiar with IPoE, googling "IPoE in Windows" gets no results. But if it is an alternative to PPPoE then I wouldn't see why Windows couldn't have an application that does it. Perhaps your ISP knows? Have you spoken to them?
    – barlop
    Dec 31 '14 at 17:06
1

Got it working by setting the modem-router into bridge mode, and then using ipconfig /release and ipconfig /renew to request an IP for my machine from the ISP's DHCP server.

Important: I had to initially disable the windows firewall before using ipconfig /renew, or the request would time out.

3
  • Looks like a PEBCAK to me. Bridge mode was mentioned, you don't address the logging in in your answer, which you asked of in your question. You asked about IPoE being an issue. State what makes you think it is doing IPoE? Your router doesn't even mention IPoE though does mention PPPoE and PPPoA zyxel.com/uk/en/products_services/p_660hw_series.shtml?t=p
    – barlop
    Jan 1 '15 at 7:48
  • @barlop I didn't have to take any extra steps to log in. I'm not using PPPoE/A so I don't need to use any username or password. My router is set to use RFC 1483 for bridging.
    – user404
    Jan 1 '15 at 12:56
  • Okay, makes sense I suppose. Unfortunate that it was just you missing a basic troubleshooting network step unrelated to the specifics of IPoA. But fine
    – barlop
    Jan 1 '15 at 15:41
0

You can disable NAT on your ISP provided gateway if it allows "ip passthru". Basically the ISP provided gateway device will "passthru" the public ip to a single device on your internal network plugged into the gateway.

If this one device the IP is passed to is a Linux box, then that box will have a public ip. if you put a second NIC in it, you can then "masquerade" however many devices behind it you desire by using iptables. in effect the Linux box will have a public ip, and be "nat'ing" for all the devices behind it. (actually, using PAT, as there is only a single public IP)

This means you can have a Linux workstation with a public ip, and still dozens of machines on a private LAN behind it. the workstation is effectively a masq'ing firewall.

Although this is how you do it, I would recommend against it.

2
  • sounds like you are describing what is also called bridge mode but then what device is going to do the PPPoE or in his case, the "IPoE"?
    – barlop
    Dec 31 '14 at 17:44
  • My gateway has no ip passthrough option :/
    – user404
    Dec 31 '14 at 18:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.