4

I have Windows Updates set to "Check for updates but let me choose whether to download and install them". However, Windows keeps changing back to "install updates automatically".

In this post I read that an antivirus can change this setting. However, I have no antivirus installed at this moment.

In this other post I read that Windows Live Essentials can cause this issue, but I don't have that installed either.

I have just reinstalled Windows 8.1 x64 today and the only other software I have installed so far is AMD Catalyst, Firefox, MS Office, and WinRAR (none of which should be changing Windows Update settings)

I've noticed that Windows Update settings have been changed after my PC restarts following the installation of updates.

This issue has already caused my PC to become unable to boot twice since I use Windows custom themes and I need to disable them before Windows updates. However, with automatic updates, I don't get a chance to disable them and then it's too late.

5
  • 1
    Run ProcMon with a filter applied to the registry key and look which process changes the setting: channel9.msdn.com/Shows/Defrag-Tools/… – magicandre1981 Jan 1 '15 at 7:56
  • 1
    If you cannot solve it you can always disable forced restarts This will give you a chance to disable your custom themes. – Moab Jan 1 '15 at 22:37
  • @magicandre1981 The settings get changed after a specific group of Windows updates (can't remember which). I've just reinstalled the OS and this time I installed all the updates before installing the custom theme so I have no way of checking which process during the updates changed it. Although I think that its likely that the setting may have been changed before the logon screen (black screen that says "installing updates" after restarting) so it may be impossible to monitor which process changes it. Anyway, after installing all the Windows updates the settings have not been changed again. – Jorge Luque Jan 3 '15 at 20:45
  • @Moab The problem is sometimes I restart it myself (like after installing a program I click the "restart now" button) so the PC gets restarted and installs the updates without me knowing. Do you know which registry key has the settings for automatically updating Windows? – Jorge Luque Jan 3 '15 at 20:50
  • 1
    Registry keys here – Moab Jan 4 '15 at 22:16
2

This happened to me too and I think I've found the reason.

After installing Windows, I usually set Windows Update to Check for updates but let me choose whether to download and install them, then proceed to install all the latest updates.

After that, I would install Microsoft Office (2013) - this leads to a whole lot of new updates being listed in Windows Update.

The key is that after installing Office (and opening up the programs eg Word, Outlook etc), a dialogue box will pop up which asks you to either Use Recommended Settings or Don't use Recommended Settings:

enter image description here Note: This screenshot for Exchange (found on internet) - normally the text is allowing it to update automatically etc, not just to provide usage feedback.

I always choose Use Recommended Settings and after a reboot Windows Update would be configured to automatically install updates again.

I haven't found a workaround to choose Use Recommended Settings and use Check for Updates but let me choose whether to download and install them, so what I always do is after choosing Use Recommended Settings, I reboot the computer and immediately go to change the settings in Windows Update to what I prefer.

Conclusion: It is indeed MS Office which is changing your Windows Update settings.

0

This just happened to me today even though I have not installed any version of Microsoft Office, or (as mentioned in some answers to this other question) Windows Live Essentials/Windows Movie Maker.

(My system is a 64-bit Windows 7 Professional; it is not connected to a domain.)

Anyway I do have F-Secure AV installed but I have had that software for over a year and have not seen this behavior before. The Windows event logs did not provide any information indicating what would have changed the setting.

However I have now made a modification to a particular group policy on my machine in an attempt to block this change in the future.

This group policy modification can be done as follows:

  1. through Windows start menu, launch gpedit
  2. in the Local Group Policy Editor, navigate to Computer Configuration > Administrative Templates > Windows Components > Windows Update
  3. in the right-hand pane, locate the policy named "Configure Automatic Updates"
  4. change the policy to "Enabled" and select the option "2 - Notify for download and notify for install" under the Options, as shown in below image.

Group Policy Setting

Windows will automatically save the setting when you click OK.

0

Load the imp updates you want then turn off windows update, check 2x a year and install the imp updates - a few bad ones et phone home ect, then turn off windows updates never accept the recommended updates or you will be sorry !

-1

i know it's a bit late, but--i just found out that there are TWO places you must make, as i had update set to only check for updates, but it did it automatically ANYWAY. you have to go into 'pc settings'-->'update and recovery' and then 'choose how updates are installed'. why does it seem like they're always trying to trick you since windows 8.1 came out??

1
  • Changing settings in one place should also change it in the other (Metro). – Rsya Studios Jun 14 '15 at 2:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.