I've been trying furiously for about 2 to 3 weeks to get the data off this drive. And I've had lots of learning while I've done it. However I still am with no data. I have used SafeCopy to make a copy of the drive. Which I then tried to mount the image. Now, the first time I did this. I did the full drive (All 6 Partitions) and I got the offset and the -o loop in and have used about every mount command I can find. However the furthest I got was this message.

NTFS signature is missing.
Failed to mount '/dev/loop0': Invalid argument
The device '/dev/loop0' doesn't seem to have a valid NTFS.

Maybe the wrong device is used? Or the whole disk instead of a partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

Now after reading around, I ended up reading that basically I'm dumb and should have just used safecopy on the partition I wanted. So this morning. I ran safecopy again on the second partition. However when mounting, I get the same message as before. At this point, I have a .img file of the second partition on the drive. I'm worried I won't be able to run safecopy many more times on the drive (if at all since this last time was a struggle) so I hopefully can just repair this img file to let me mount it. If however I have to get the full image again, I will do so. Below are the last couple of commands and their output.



I'm doing all this on a laptop I dedicate to this sort of thing. And I'm running Kali Linux 1.0.9a 64-Bit.

mount -o loop -t ntfs-3g /media/DBU/Devin2.img /mnt/tmp

NTFS signature is missing.
Failed to mount '/dev/loop0': Invalid argument
The device '/dev/loop0' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?


I did try the above without adding the "-3g" and without the "-o loop" and its the same result.


file /media/DBU/Devin2.img

/media/DBU/Devin2.img: ASCII text, with very long lines, with no line terminators

(When I did this on the full partition, I did not get that, it actually knew it had partitions)


fdisk -l /media/DBU/Devin2.img

Disk /media/DBU/Devin2.img: 452.9 GB, 452919820288 bytes
255 heads, 63 sectors/track, 55064 cylinders, total 884609024 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x62446142

Disk /media/DBU/Devin2.img doesn't contain a valid partition table
  • OK - whatever you do - DO NOT try to write to the drive, and maybe not even power it up anymore - give people here some time to read and understand your issue. – arch-abit Jan 1 '15 at 2:04
  • Drive: What is it, a hard drive or solid-state, or something else? Capacity? Drive: Is it MBR or GPT? Mount: How did you originally mount the drive? Internal SATA, USB, other? -3g is to write to NTFS, again, do not use it on this drive! – arch-abit Jan 1 '15 at 2:16
  • Yeah, I have not plugged it in since the last safecopy. the drive is a Seagate Momentus 5400RPM, 500GB Hard Drive. I believe it is MBR Since it came with a Windows 7 Laptop. The drive struggles to mount normally when plugged in (Parted -l freezes for a while, file explorer sees the partitions but I can't do anything). I mounted it with a powered external enclosure (Its the only external reader I have that works well with safecopy). And thanks for the clarification on -3g. Will not use it again. – Tyler C Jan 1 '15 at 2:51
  • It is HDD and it is most likely an MBR, so there is a good chance it can be read and the data rescued - as long as the platters holding the data inside the drive are intact - unless you wrote to the drive during your rescue attempts. Some good news for you to start 2015 with - since you are 'furiously trying'. New year celebrations are about, so sit tight, and keep the drive off-line. – arch-abit Jan 1 '15 at 3:11
  • That would be amazing, and to clarify. I never specified to safecopy ntfs-g3. The only thing I used that on was the .img file I got from safecopy. So as long as safecopy --stage1 never writes to the drive we should be good. Also, thanks for responding during the holiday. – Tyler C Jan 1 '15 at 4:06

It looks to me you have at least four choices - there are probably more. The last choice is forget about it, but we'll come to that.

The first choice is to decide if you want to go the professional data recovery service way, the price could be as low as 300 US when you are fortunate enough to have the HDD crash just the right way - or it is healthy but the user have no idea how to use it. This is, by the way, near to the same price you pay for two or three quality HDD these days? People working with or experienced with the service are going to help you out. When you do, and the recovery service tells you to 'forget about it' it is probably final.

The next choice is to have a step-by-step recovery plan done by yourself, to power-up the HDD and use whatever options you choose. This by necessity is also your last choice (forget about it). Once you take matters in your own hand you are [basically] on your own. I wrote basically, not totally, I am responding after all?

The third option is to keep the HDD off-line, but re-read your own post every time someone asks you or makes a suggestions, and update your knowledge. Soon enough, if you do your research, it all becomes clear if you should just forget about it, or attempt my first or my next choice.

I would recommend the third option. Once you describe the problem to yourself there is no need to describe it here. Your choice of OS, file system, your way of recovery from a disaster, and a number of other assumptions of mine makes it obvious - in the future do not trust valuable data to learning experiences.

Happy New 2015 to You!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.