0

I have mounted an xp ntfs share drive on my raspberri pi with the command sudo mount -t cifs -o guest //192.168.1.103/share1 /mnt/mtmy

The only way that I can edit and save files in this directory from raspberri pi is to use the sudo command. eg. sudo leafpad etc. Unless I precede with sudo I have a permissions problems and cannot save my changes.

I have tried sudo chmod 666 -r * from the mtmy location and I get "permission denied" response as it recurses. I have also tried sudo chown and got a similar response.

I can access this windows share from other windows machines with no permissions problems so I don't think the problem is related to windows sharing. However, it appears that not even using sudo can make the permissions changes in rpi to grant permission to other users.

  • try chmod 777 -r /mnt/mtmy/ (or 666 or whatever you want) – cutrightjm Jan 2 '15 at 2:06
  • ok, I got thispi@raspberrypi /mnt $ sudo chmod 777 -r /mnt/myny chmod: cannot access 777': No such file or directory chmod: changing permissions of /mnt/myny': Permission denied – user3799318 Jan 2 '15 at 3:45
  • You have the drive mounted already, yes? Also, there's a / on the end of myny/ – cutrightjm Jan 2 '15 at 3:50
  • yes, it is definitely mounted and I just tried adding the "/" on the end and it did not make a difference, same fail message previously posted. As I said, root can add/del/modify files in /mnt/myny/ but a standard user can only open files to view but cannot save or modify. And for whatever reason root cannot do a chmod or chown. – user3799318 Jan 2 '15 at 18:30
  • I have since discovered that this problem is not unique to raspberri pi. I am running debian on a laptop and when I mount that same ntfs network drive only su has rw permission but it does not have authority to run chmod or chown. – user3799318 Jan 2 '15 at 22:14
0

it is not possible for mounted ntfs permissions to be managed by su. They only can be managed as part of the mount command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.