1

I have a USB drive that shows up as Lexmark USB in Safely Remove Hardware but I cannot find it in My Computer. The only things that show up in My Computer are the computer's hard drive and Network Places.

I am running Windows 7 64-bit Home Premium.

I have tried using the Windows Troubleshooter and that doesn't do anything. It gets stuck in a loop from "Checking device status --> Checking device something --> Checking issues with device --> Checking device status"

The USB is recognized perfectly fine on another machine running Windows 8.1 64-bit.

2

Based on another machine being able to read from it fine, it sounds to me like it is most likely set to dynamic and/or a drive letter is simply not being assigned.

Click Start and right click on Computer and click Manage. On the Computer Management Window, go to Disk Management.

From here, you should be able to see a row/line in the bottom section of the page that shows your drive. Simply right click on the volume and select Change Drive Letter and Paths

enter image description here

On the dialog that comes up, select Add, and the drive you want.

If you can't get this far/If it says Dynamic on the left (where it shows basic in my screenshot), simply right click and chose initalise, however if this is the case, Disk Management would have said that a dynamic disk was detected when you first opened it.


Just to note: There is also a licensing restriction on dynamic disks that I just can't remember off by heart or from doing a quick Google. I believe it was where the home/basic editions couldn't read them... but, I have a feeling that was just with Windows XP.

  • Thank you, this worked for me. Had no idea I had to assign it a Drive Letter for it to be recognized, thank you so much! – yuritsuki Jan 3 '15 at 0:30
  • 1
    You are welcome, And... You don't always have to do it... There are some weird situations where it occurs. Sometimes it can be bad tools/AV that intercept the mount, other times it can be a registry conflict, or, I remember a patch a while ago (that was fixed) which stopped auto mount.... Go to an elevated command prompt (right click cmd and do Run as administratior, then type Diskpart, and then type automount, if it says ¬Automatic mounting of new volumes is disabled` just type automount enable. – William Hilsum Jan 3 '15 at 0:35
  • This happens most often when the drive letter used to mount on the last computer is not available for use on the current one (ie. There is another drive already using that letter). – James Jan 3 '15 at 6:00
  • @James - Where on the drive is this remembered/stored? ... First time I am hearing of it, I could swear I get different letters on different machines - but, it is interesting/makes sense and I want to look in to this! – William Hilsum Jan 3 '15 at 12:54
  • @William: I'm not sure, I've never looked into it, but I noticed the behavior after a few years of using portable drives. I suspect it's stored with the partition info. – James Jan 3 '15 at 17:13
2

It's likely that your USB drive was not assigned a valid drive letter. To fix this:

  1. Right-click My Computer, then click Manage
  2. Click Disk Management in left pane.
  3. Right-click your USB drive and choose Change Drive Letter and Paths...
  4. Select an available drive letter from the list.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.