1

I have given up trying to find a proper workaround or solution to install MySQL Workbench + MariaDB so I decided to install the official stack provided by MySQL so I enabled their YUM repository using their RPM for Fedora 21 available at their download page but when I tried to install Workbench yum throws the following message:

There isn't any package named mysql-community-workbench.

How long do I have to wait until they enable workbench on their repositories? Although I can use the el7 build, the result rows are all blank so it's not useful at all.

2 Answers 2

4

I've tried with mysql-workbench-community-6.2.4-1.fc20.x86_64.rpm but still result rows are all blank. Maybe one of the dependencies of mysql workbench is not compatible with it in Fedora 21 (in other forums glib is mentioned, see: stackoverflow.com/questions/24739198/mysql-workbench-not-displaying-query-results ).

But those answers are made only for Ubuntu, not Fedora.

Another option that I've found here: bugs.mysql.com/bug.php?id=72585

To do that, do the next steps:

  1. Download source code from dev.mysql.com/downloads/workbench/
  2. Be sure to have latest glib libraries and dependencies (use yum to get it)
  3. Be sure to have boost C library (use yum to get it)
  4. Unpack mysql-workbench source code tar.
  5. Change to source code directory and make a new directory called wb-build; change dir to wb-build.
  6. Backup mysql-workbench-community-6.2.4-src/backend/wbpublic/sqlide/recordset_text_storage.cpp
  7. Edit file: mysql-workbench-community-6.2.4-src/backend/wbpublic/sqlide/recordset_text_storage.cpp

Use vi or gedit and change the method call ‘ReloadIfChanged()’ to ‘ReloadAllIfChanged()’ in the lines 206, 215 and 224. Then save your changes.

  1. Make it compile as root inside wb-build directory:

    • cmake .. -DBUILD_CONFIG=mysql_release
    • make
    • make install

This method ReloadIfChanged() is deprecated: see code.google.com/p/ctemplate/ Ctemplate's method stops the make process if not changed.

3
  • 1
    Welcome to Super User! If you have a NEW question, please ask it by clicking the Ask Question button. If you have sufficient reputation, you may upvote the question. Alternatively, "star" it as a favorite and you will be notified of any new answers. See the tour for why Me Too answers are not appropriate here.
    – Tim
    Jan 9, 2015 at 21:30
  • I'm sorry Tim, I'll take care about with you mentioned. I've changed my "answer" to a real answer. Regards Jan 9, 2015 at 22:56
  • So basically I'm rebuilding mysql from its repos right? well, I'll give it a shot, thank you!
    – arielnmz
    Jan 14, 2015 at 18:34
0

mysql-workbench is not yet available for Fedora 21 and I'm not sure whether this package is ever included in their YUM repository.

The best approach is to download mysql-workbench rpm for Fedora 20 (http://dev.mysql.com/downloads/workbench/6.2.html) and install it using yum localinstall < rpmfile >

3
  • Thank you, and what about its dependencies?
    – arielnmz
    Jan 7, 2015 at 12:59
  • yum would take care of the dependencies.
    – libregeek
    Jan 7, 2015 at 13:55
  • Attempting to install the Fedora 20 package does not work. The difference in ctemplate cause the result set in the UI to be blank, see here: unix.stackexchange.com/questions/173797/…
    – Brady
    Jan 17, 2015 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.