I am running a 64-bit version of Windows 7 Home Basic. I am trying to update the Windows but the update fails with an error code 80072EE2. I am connected to the internet through proxy.

Here are some things listed in my WindowsUpdate.log:

Access type: No proxy
WSUS server: <NULL>
WSUS status server: <NULL>

Then the download manager is restoring some persisted download calls. Then,

Initializing Automatic Updates
WARNING: SendRequest failed with hr = 80072ee7. Proxy List used: <(null)> Bypass List used : <(null)> Auth Schemes used : <>
UpdateDownloadProperties: download priority has changed from 1 to 2.
WARNING: Failed to change download properties of call, error = 0x80070057
WARNING: WinHttp: SendRequestToServerForFileInformation MakeRequest failed. error 0x8024402c
WARNING: WinHttp: SendRequestToServerForFileInformation failed with 0x8024402c
WARNING: WinHttp: ShouldFileBeDownloaded failed with 0x8024402c
Error 0x8024402c occurred while downloading update; notifying dependent calls.

There are very many errors/warnings and some other things listed in the log file. I have copied above the ones I thought are relevant to my problem.

Note that I have tried the solution provided on the Microsoft website but that was unable to solve my problem.

Can someone help me resolve this error?

  • I think the proxy is blocking Windows Update, can you work withou a proxy and try again? 80072ee7 means the microsoft servers are too busy, but I rather think in your case it's being blocked.
    – Alex
    Jan 4, 2015 at 17:55
  • @Alex: I can't work without proxy.
    – crisron
    Jan 4, 2015 at 17:57
  • I think you have to use Solution 1 from the answer below, if you can't use that, I don't really know howto update. Maybe connect the pc/laptop somewhere where you don't have to use a proxy.
    – Alex
    Jan 4, 2015 at 18:01
  • 80072EE2 = ERROR_INTERNET_TIMEOUT Which Av suite do you use? Jan 5, 2015 at 6:17
  • @magicandre1981: None
    – crisron
    Jan 5, 2015 at 15:47

1 Answer 1


Solution 1

Check if you are using a proxy server. If you do, double check the settings in the Internet Explorer and make sure that the proxy does not require a username or password to connect. If it does, the easiest way is to disable the proxy server during the duration of the windows update, although you can also create a workaround by setting your firewall to allow the connection to the Windows Update directly without going through the proxy.

Solution 2

If your computer has been infested with spyware in the past – or it is at the moment – then the spyware might have modified your Internet Explorer settings to use a proxy server. Open the cmd.exe program (by typing CMD in the start menu) and issue the following command: netsh winhttp import proxy source=ie

Solution 3

Some dll files might have become unregistered – due to various factors – which could trigger the windows update error 80072ee2. In this case, open cmd.exe, and register the following dlls: oleaut32.dll, jscript.dll, vbscript.dll, msxml.dll, softpub.dll, wintrust.dll, initpki.dll, cryptdlg.dll. You can register a dll by typing regsvr32 {name of the dll}.

Solution 4

This is the rarest occurrence that may cause the windows update error 80072ee2, but your computer’s MTU setting might be incorrect. In this case, you simply have to set the MTU value to 1492 and try the windows update again.

Solution 5

Also, please check this solution as well. http://www.technibble.com/forums/showthread.php?t=22840 It has to do with Windows Updates being set to receive them via WSUS.

These are all possible solutions to the windows update error 80072ee2. In case you still can not fix the error, leave a comment below and we will assist you.

From: http://theitbros.com/how-to-solve-the-windows-update-error-80072ee2/

  • Running the command with msxml.dll and initpki.dll is giving error. I ran the command as administrator.
    – crisron
    Jan 4, 2015 at 18:38
  • Try to run cmd as administrator and run sfc /scannow, don't think it will help, I think the proxy is the problem...
    – Alex
    Jan 4, 2015 at 18:54
  • There has to be some solution for this proxy issue
    – crisron
    Jan 5, 2015 at 15:48
  • 1
    Maybe you can try this netsh winhttp reset proxy and try again.
    – Alex
    Jan 5, 2015 at 16:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.