I installed home brew on Yosemite and it messed up the System built-in framework. I couldn't use the Ruby gems already installed or the new ones installed after Homebrew. Instead of fixing all the mess that Homebrew left, I rather prefer to reinstall Ruby from the official installers. I know it's possible but I haven't had luck so far.

This is what I've tried from the answers to "Is it possible to reinstall/fix Mac OS X's system ruby without doing a complete OS reinstall?".

I downloaded Yosemite installer from the App Store, and tried to install Ruby.framework with Pacifist. Pacifist just gets stuck preparing the installation. It's Pacifist's latest version by the way.

Also, tried looking in the Installer bundle's content, but there is no such thing as the Xcode Tools folder.

  • There is some ambiguity in your question. I'm having a hard time sorting out which parts you've tried and in what order. Please paste your exact steps and error messages and possibly screenshots. Please link to the specific answers (use the 'share' link) you've tried.
    – David J.
    Jan 5, 2015 at 18:49
  • Why is Pacifist needed? (I'm not familiar with it.) It seems to add complexity (e.g. something else that can fail).
    – David J.
    Jan 5, 2015 at 18:50
  • @DavidJames Sorry, but I can’t do that, look at the specificity of the question I’m referring to. Someone with expertise would know immediately what I’m talking about. Rather I prefer to dig deeper the issue, and then respond to my own question.
    – rraallvv
    Jan 5, 2015 at 19:06

2 Answers 2


So, this is how I did:

1) Downloaded the Yosemite installer from the App Store

enter image description here

2) Show contents of "Install OS X Yosemite.app"

enter image description here

3) Open Contents/SharedSupport/InstallESD.dmg

enter image description here

4) Install Packages/Essentials.pkg

enter image description here

  • You rule! How on Earth did you find it?
    – Aleks N.
    Jun 2, 2015 at 8:05
  • Has anyone else tried this? @Alexi did this work for you?
    – Ryan Ore
    Jun 30, 2015 at 15:04
  • @RyanOre Frankly I don't remember very well.
    – Aleks N.
    Jun 30, 2015 at 15:17
  • unfortunately in Mojave, Essentials.pkg does not exist anymore, the only packages are Core.pkg, EmbeddedOSFirmware.pkg, FirmwareUpdate.pkg, OSInstall.mpkg and SecureBoot.pkg.
    – fabb
    Nov 2, 2018 at 12:12
  • @fabb I consider myself now among the latest group of people that upgrade their systems, sadly, since they started to rush macOS releases and diminishing the quality of their products. Although still prefer macOS above other OSes, even Linux. Hopefully they moved the Ruby framework to some other package.
    – rraallvv
    Nov 2, 2018 at 12:49

By installing Install OS X Yosemite.app -> Contents -> InstallESD.dmg -> Packages -> BSD.pkg, /usr/bin/ruby was installed on Yosemite 10.10.5.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.