14

I just tried to install some updates for my laptop, and now it is stuck in an automatic repair loop. From what I've been able to find so far in the logs, I believe it is some problem with the registry.

The system restore tells me that there are multiple restore points available, including one it created just before attempting to install the updates. However, it tells me that I can't restore my C: drive because "You must enable system protection on this drive".

Is there a way that I can enable system protection on my drive through the command prompt? Failing that, is there a way to restore just the registry (either manually or automatically)? I've been able to open up regedit, though I have no clue what part of the registry is corrupted.

Update:

Here's the only relevant thing the SrtTrail.txt log has to say about the issue:

Root cause fount:
---------------------------
Registry is corrupt.

Repair action: System Restore
Result: Failed. Error code = 0x1f
Time taken = 588875 ms

Repair action: Registry roll back
Result: Failed. Error code = 0x3
Time taken = 0 ms

Update 2:

I booted using the legacy boot and managed to surface a new error:

Realtek PCle FE Family Controller Series v1.27 (10/31/11)
PXE-E61: Media test failure, check cable

Looks like this is a red herring. This just means that I can't boot from the network.

9
  • Do you have a backup of registry? Did you faced any power down/system shutdown during the installation of updates? Jan 6, 2015 at 7:09
  • @RenjuChandranchingath I assume the restore point includes a backup of the registry, but I don't have any backup separate from that.
    – Rob Watts
    Jan 6, 2015 at 7:11
  • @RenjuChandranchingath And no, the system was fine (no power down or shutdown) until I rebooted to install updates
    – Rob Watts
    Jan 6, 2015 at 7:13
  • From a powershell type enable-computerrestore -drive "C:\". Jan 6, 2015 at 7:25
  • @RenjuChandranchingath Do you know how to start the powershell from the command prompt?
    – Rob Watts
    Jan 6, 2015 at 7:30

1 Answer 1

27

Update May 2022:

Even though I wrote this for fixing an issue with Windows 8.1, others have found that it also works for more recent versions of Windows (up to Windows 11 so far). If you happen to be the first person to try this with a newer version of Windows, please comment on whether or not it worked.


Looking at a an article for Windows 7 about the same issue, I found a suggestion to use the following command:

Rstrui.exe /offline:C:\windows=active

Rstrui.exe opens up the system restore window. I'm not sure what the argument means, but it made it so I could actually use the restore points! Yay!

Unfortunately, this did not completely fix my problem - the system restore failed. The error message implied that it had something to do with the registry. So, using the command prompt I went into C:\Windows\System32\config and renamed two of the registry files:

ren SYSTEM system.001
ren SOFTWARE software.001

After doing this, I ran the system restore again (using the same argument as I did the first time) and it worked! I was able to log back into my computer!

9
  • I can’t believe it but this worked for me as well. It even threw fricking errors and said restoration failed, but it still was able to boot correctly and when logged in it said it did succeed. Oct 31, 2017 at 4:12
  • 3
    I guess that rstrui /offline:c is enough.
    – Alex78191
    Mar 27, 2019 at 23:35
  • 1
    Thanks! It also worked for me. Sep 14, 2019 at 22:22
  • 1
    Works in Windows 10.
    – Neil
    Jul 24, 2020 at 2:50
  • 1
    This has just helped me to recover from "unrecoverable" CRITICAL_PROCESS_DIED BSOD in windows 11, thanks!
    – vearutop
    May 9 at 23:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.