1

I'm getting extremely strange results in Photoshop CC (2014.2.2 release). After switching a few times between programs back to Photoshop I get the following artefacts. Only remedy seems to be restarting Photoshop. Even stranger, saving the current file in a JPG will even save the artefacts to the file.

enter image description here

Couldn't find any related problems by good ol' fashioned Googling. Could this be a Photoshop bug or maybe even a damaged CPU?

Edit: Here is a animation showing how this affects in practice.

enter image description here

15
  • Are you using OpenGL? More likely to be an issue if your other apps use it too. Looks like a backbuffer issue. – Tetsujin Jan 6 '15 at 14:26
  • @Tetsujin would the buffer have any impact on how it saves? – Dave Jan 6 '15 at 14:30
  • not certain, tbh. Would be easy enough to switch off OGL support in pshop & see if it stops happening. Prefs/performance to en/disable it 'Use Graphics processor' or tweak the amount of RAM OGL can use in prefs/3D [it will use OpenGL for more than just 3D, but they're the only 2 real tweak points.] – Tetsujin Jan 6 '15 at 14:36
  • I seem to have OpenGL enabled. "AMD Radeon HD 6970M OpenGL Engine" I'm now disabling it, I'll get back asap with results. BTW, I'm also using Adobe Flash CC simultaneously, might that cause any problems? – Ambidex Jan 6 '15 at 14:41
  • Sorry, I really only use photoshop, but I've experienced issues on various machines with using OGL on 2 simultaneous apps - though also by not assigning it a good memory usage in the first place, allowing for other apps & total system/GPU RAM - so that's next to play with if still no joy – Tetsujin Jan 6 '15 at 14:48
0

Turn off hardware acceleration inside Photoshop preferences.

The issue, like everyone said, is a fault in openGL. Turning hardware acceleration off should help.

1
  • 1
    OpenGL is involved only in rendering the image on the screen. The problem here involves the image being corrupted. The OP also commented that the problem occurred after disabling OGL. – fixer1234 Aug 21 '15 at 17:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.