1

I use one of those dns services that let you bypass region restrictions on Netflix and similar sites. However I noticed that recently it stopped working, even though I set up the service's dns addresses manually in the connection's settings.

After doing an ipconfig /all command:

ipconfig results

...I see that the first two DNS addresses are unknown to me and not set up anywhere on my local machine - they must be coming from DHCP.

Is there a way to set up my system so that the DHCP's DNS servers will be ignored? I have no way of connecting to the router, as it came from my ISP and is completely locked down.

| improve this question | | | | |
  • 1
    Hasn't Netflix just updated itself to prevent this? This also seems unethical and against their terms – Dave Jan 6 '15 at 15:51
  • How does this seem unethical? I am paying the full price for their service. – Rafał Saltarski Jan 6 '15 at 15:52
  • 1
    Its unethical because you're violating the Netflix Terms of Use. 6.c. You may view a movie or TV show through the Netflix service primarily within the country in which you have established your account and only in geographic locations where we offer our service and have licensed such movie or TV show. You're obviously not licensed to view the content in your current location, or you wouldn't have to use special DNS servers to bypass the geographic checks. – heavyd Jan 6 '15 at 16:15
  • I would argue that TOS is not law since what I do is perfectly legal in my country, and netflix has no business knowing where I live, but I suspect that this is not the place to discuss that now is it? – Rafał Saltarski Jan 6 '15 at 16:35
  • 1
    Nobody said anything about it being legal or not, it was said that its unethical. But you're right, this isn't the place. – heavyd Jan 6 '15 at 18:13
2

The addresses you're talking about are IPv6 addresses, so you'll need to need to configure your IPv6 settings. You can do that the same way you would IPv4, except instead of selecting "Internet Protocol Version 4 (TCP/IPv4)" from the network adapater properties window, you need to select the "Internet Protocol Version 6 (TCP/IPv6)."

Screenshot

| improve this answer | | | | |
  • I see that they are IPv6, but I would like a setting to specifically ignore them, as they are NOT set up anywhere in my connection settings. – Rafał Saltarski Jan 6 '15 at 15:49
  • 1
    In the properties dialog either set an IP for the Primary DNS, or disable IPv6 by unchecking the checkbox. If you don't have an IPv6 server you want to use, you could try using ::1, which is your localhost. – heavyd Jan 6 '15 at 16:07
  • Setting the IPv6 DNS server to ::1 fixed it! Thanks a lot. – Rafał Saltarski Jan 6 '15 at 16:11
1

The first two addresses are of the type IPv6 and not IPv4 that the last two ones are. That may be the reason you don't recognize them.

(Below instructions are for Win7 which should be very similar, if not identical)

To manually specify IPv4 dns servers while using DHCP: Open up your "Network and Sharing Center". Click "Local Area Connection" for the network card. On "Local Area Connection Status", click Properties. Select IPv4, click Properties. Select "Use the following DNS server addresses: Manually specify the addresses of the DNS servers you wish to use.

If you arent using IPv6 at all you may want to uncheck that on the Properties window.

| improve this answer | | | | |
  • I have manually specified the IPv4 dns servers, otherwise I wouldn't be seeing them in my screenshot. The IPv6 ones are not specified anywhere on my machine, yet DHCP still assigns them as primary DNS servers - I would like to disable that and make my computer only use the DNS addresses I provided. – Rafał Saltarski Jan 6 '15 at 15:53
  • Disabling IPv6 fixed the issue temporarily so I am upvoting your answer, but it is not the most elegant solution so I will keep the question open till I figure out some otner way. – Rafał Saltarski Jan 6 '15 at 15:57
  • Did you try keeping IPv6 enabled and manually specifying dns servers and leaving the fields empty (for IPv6)? That could potentially work. – Christian Isaksson Jan 6 '15 at 15:58
  • Tried that, but after I close the window and open it up again it's set to "automatic" again. Seems like this Windows doesn't like setting those fields empty, and the problem might be harder than I initially thought... – Rafał Saltarski Jan 6 '15 at 15:59
  • I guess the solution then would be to identify the source of the addresses. If your ISP DHCP server is adding them, then its probably for a reason and if its some third party software then you could always uninstall that. – Christian Isaksson Jan 6 '15 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.