2

I am trying to get a new 4TB Seagate USB drive to work with Xen 6.2 and a Windows 2008 R2 virtual guest.

The Xen host sees the drive fine, fdisk -l lists it with the correct capacity, etc. I can even use gdisk to create a partition and format it with ext3, then mount and transfer data with no problems. However, I tried to create a local SR with XenCenter but the process fails at the point I attempt to add a virtual disk of any size.

I also tried Attach Disk to directly attach to the virutal guest, where it is detected by Windows, but due to the drive having 4k native sector size, the capacity reported is 30+ TB, and any attempts to perform operations on the drive yield I/O errors.

I installed the 4k sector support patch to Windows 2008 R2, but Disk Manager still shows a 30+TB drive. (See here, here, and here)

Am I going to have to return this drive and purchase one with emulated 512 byte sectors? Or can anyone point me to a solution?

Thank you!

Updates:

Here's a screenshot:
 (29,808.19 GB) –  Ryan Griggs Jan 7 at 2:33

Attempts to initialize yield I/O errors.

I found a note by someone on Amazon stating that the Seagate drive has native 4k sectors and doesn't work with Windows Backup/etc.

Hotfix for windows 7/2008 R2 only supports 512e disks, not native 4k: support.microsoft.com/kb/2553708

More info here about support for native 4k. Looks like only Windows 8 and Server 2012 support it.

Using 4k disks with Hyper-V

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.