3

I have a virtual Windows 7 machine running in VMWare Workstation. Every time I reboot, Windows updates are configured and installed, the boot process fails, and finally the system attempts and fails to automatically repair itself. None of the manual "advanced" repair options seems to get past the initial stages, either.

I've tried deleting C:\Windows\winsxs\pending.xml and C:\Windows\winsxs\reboot.xml, but the updates still get installed on reboot. This appears to mean that the files are already installed, so I've tried uninstalling the last several installed updates. Specifically, I uninstalled the top 4 non-.NET updates in the list shown below (in the picture). I suppose I could keep randomly uninstalling these one-at-a-time until my computer successfully reboots, but that's a very slow process.

I don't see any option to cancel or hide pending updates in the Windows Update settings window; when I right-click on an update (whether pending, successful, or failed) the only options are to view details or copy details.

I'm not sure what is causing Windows to fail to boot and attempt the auto-repair process, but it may have something to do with the Windows Embedded Standard 2009 toolkit and its associated updates (all the December roll-ups released thus far, plus the IE8 components). Or it may not; I'm not really sure how to tell, but that's just about the only thing I even have installed on the machine. I suppose it could also be a VMWare Workstation problem.

I tried running the auto-fixer here, but it said no problems were detected.

I also tried the suggestions from Itai and Moab here, to no avail; the gpedit fix didn't change the reboot behavior, and as noted previously, I don't see any option to "hide" these updates (and in any case I believe the guilty files are already installed).

....any ideas? Can pending updates be rolled back? Is there a way to figure out which update is causing the boot process to fail, assuming it's even an update?

enter image description here


EDIT

This is preventing me from cloning the VM, which would be EXTREMELY helpful for my team at the moment.

EDIT 2

I've found that I can "imitate" cloning by simply copying all the files for the machine. This is probably not as robust, and it's not as convenient, but the immediate needs of my team are met.

  • Have you tried to rollback to a system restore point that is from before the destruction by Windows Update? – harrymc Jan 12 '15 at 18:42
  • @harrymc I have not, but I'd rather avoid that if possible, because quite a bit of the work I'm attempting to preserve by cloning the machine has been done since the problem started. – Kyle Strand Jan 12 '15 at 19:40
  • This being a VM, one can always try things while keeping a copy. Try to reset Windows Update (reference here and here). If this doesn't help, why not try a Repair Install. If one works, be careful about redoing Windows Update (I can give a few hints there). – harrymc Jan 12 '15 at 20:41
  • If you want to clone the VM you must shutdown the VM. If done within a reboot it will not harm the virtual disk. – user242903 Jan 16 '15 at 13:32
  • @nicolap8 The whole point of the question is that the VM wrecks itself on boot. – Kyle Strand Jan 16 '15 at 16:28
3

Before anything, you should try sfc /scannow when you're in WinPE. This will likely not work if windows updates are causing the issue, so continue below to see alternative steps for windows repair.

Find your Windows 7 disc, and boot into it. Get to the WinPE console within the Windows Installation menus to search for the pending.xml file in your C:\Windows\WinSxS folder. If it exists, try renaming this file. Don't delete it or else your computer may be unusable.

Then type in sfc /scannow at the command line. If this still fails, you may need to use the following syntax instead: SFC /SCANNOW /OFFBOOTDIR=C:\ /OFFWINDIR=C:\Windows

This command may run for a long time, and will spit out a CBS.log file. You may need to stop the scan if it lasts more than 12 hours by using CTRL+C, but this should not harm your Windows installation.

If bootup fails, boot back into WinPE and rename the pending.xml file back to its original file name. If rebooting doesn't work after all of this, then an in-place windows upgrade is likely required. See below for more info:

How do I repair the corrupted files found by sfc /scannow? "Windows Resource Protection found corrupt files but was unable to fix some of them."

2
+150

This KB article has a lot of things to try.

Microsoft also has a troubleshooter for Windows Update. It may point out the offending update that is failing. I don't know if this is the same one you tried, but it's worth a shot.

If all else fails, "net stop WuAuServ" and disabling the update service can stop the vicious cycle of updating and failing and allow you to clone your vm for your team.

  • Unfortunately, I did not have time to try these suggestions before the bounty expired, but I gave it to you anyway. – Kyle Strand Jan 19 '15 at 19:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.