4

I have an issue with my touchpad. Every time I scroll, there's a 1sec (not sure) delay before the scrolling stops when I lift my fingers from the touchpad, and it will automatically zoom when I press control afterwards. As a laptop user, I really want to switch tabs easily with ctrl tab etc...

For example, I'm on a webpage, I scroll all the way down, lift my fingers from the touchpad and I want to change tabs directly with ctrl+tab. The page than zooms in or out because I pressed control during the after-scroll delay...

Is there a way to disable this or is this a bug ? I don't think it's an issue with the touchpad sensitivity though.

Thanks

(using an Asus X751L)

2
  • Have you researched on Asus sites to see if this is a common thing? Is it possible the machine is just suffering from lag? – killermist Jan 7 '15 at 15:25
  • @killermist this is a common issue on ASUS laptops – IvanRF Mar 2 '16 at 14:56
2

I came across your question while facing the same issue on my Linux-powered laptop though I haven't found a hint of what OS you use.

If you use Linux, this info will be relevant to you. However, it was concluded that there is no way to implement a fix to this issue in the current X-server driver. There are some bug reports in different bug trackers:

The root cause is obviously in X-server and others report consequences. However, it is concluded that it is not fixable in current X-server driver. The only workaround is to disable or minimize inertial scrolling:

Decreasing "CoastingSpeed" (i.e. to 5) limits the damage, but doesn't seem to solve the problem.

Increasing "CoastingFriction" does a better job, since it reduces the amount of time in which the scrolling will continue. With a value of 200, problems are much more rare. It still find occasionally some Firefox pages involuntarily zoomed out, when I scroll them then Ctrl+PgUp to another tab, but not crazy levels.

So resuming: 5 and 200-300 are optimal parameters, but the mechanism is simply buggy, though I don't know at which level. Scrolling "memory" should stop flowing when another key is pressed.

1

I solved this problem on my Asus N552VW (and I think is a common problem for all the Asus computers) this way:

Go in C:\Program Files (x86)\ASUS\ASUS Smart Gesture\AsTPCenter\model\ and edit the file InertiaSetting.ini as Administrator.

Edit the field MaxInertiaSeedDelta=100 to MaxInertiaSeedDelta=0 and save.

Restart your computer (or Asus Smart Gesture) and enjoy.

At the beginning, the new behaviour seems weird and scrolling is not the same as before, but the annoying problem of zoom-in when doing anything regarding CTRL will be only an old, bad dream.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.