22

Excel converting value 0503E000 to 5.03E+02 in any cell automatically in CSV I tried to convert it to text number and general but after i save it and reopen it again it goes back to 5.03E+02

How do I stop this from happening?

  • just resize the column width and it should be displayed normally – Scorpion99 Jan 7 '15 at 20:47
  • Have you tried formatting the cell as text before entering the text? – CharlieRB Jan 7 '15 at 21:00
  • tried resizing and formatting as text already no go .... – CrashOverride Jan 7 '15 at 21:02
  • If you need to use the value as a hex number (i.e. you can't have it as a text string), you can nest DEC2HEX and HEX2DEC strings for the original number (e.g. =DEC2HEX(HEX2DEC("0503E000")) for your example). It may not help if you need to manipulate the csv file without it containing formulae, but it's another option besides formatting as text. – Myles Mar 22 '18 at 17:46
16

I think the key issue here is that you are using a CSV, which does not have the cell type embedded in it. Excel automatically tries to interpret the cell as having a scientific number which is why you are seeing 5.03E+02 instead of 0503E000.

Try creating an Excel workbook and formatting all of the cells as text, and then pasting in the data. I tried it in Excel 2013 and it worked.

  • Yeah it works in Workbook, But unfortunately we have to use CSV for this purpose.....pity – CrashOverride Jan 7 '15 at 21:29
  • So don't use Excel to view the contents, or run a macro on the cell, to convert it back or use slightly different syntax if you used 0x before the value I don't belive it would convert – Ramhound Jan 7 '15 at 21:32
  • I think we may have to lay this off ... because if we open it in another editor like notepad or notepad ++ it has the correct value....so I think cell has the correct value just displaying it wierdly in scientific notation.... – CrashOverride Jan 7 '15 at 21:45
25

If you can convert or control the CSV format, you can force a column to parse as text in Excel by wrapping it in double quotes and prepending an equals sign.

Excel will carelessly discard precision in this format:

Value,0503E000,1234123412341234

Or even this format:

Value,"0503E000","1234123412341234"

Converting it to:

Value  |  5.03E+02  |  1234123412341230

However, adding the equals sign forces Excel to begrudgingly preserve your data:

Value,="0503E000",="1234123412341234"

…which opens as:

Value  |  0503E000  |  1234123412341234
  • 1
    Great solution when pasting from SQL – SeaSprite Aug 23 '17 at 20:24
  • 1
    Also great solution when import data via "Get external data" in "Data" menu of Excel. – Mohsen Abasi Sep 5 '18 at 11:00
  • 1
    Great solution. The only (small) drawback is that you'll end up with formulaes instead of values. So just copy everything and then paste values, which will lead to a somewhat smaller Excel file. – Stef Jan 28 at 9:59
8

Instead of Opening" the CSV file in Excel, select to Import the file (in Excel 2007-2010 you would navigate to the Data Ribbon / Get External Data / From Text). Not sure about 2013 but there should be something similar. When you do that, the Text Import wizard will open and afford you the opportunity to format the column containing that Value as Text, before Excel (not so helpfully) changes it to a numeric value.

  • 1
    This. I almost never open CSV files directly. – pepoluan Jan 9 '15 at 15:31
  • @pepoluan I don't understand what you have written. – Ron Rosenfeld Jan 10 '15 at 0:33
  • Which part exactly you don't understand? – pepoluan Jan 10 '15 at 14:55
  • 4
    @pepoluan Thanks. Had I understood this, the rest would have been clear. Guess I'm getting old :-( – Ron Rosenfeld Jan 10 '15 at 15:49
  • 1
    I was hopeful that using "this" as a complete sentence would have died a quick death, but 4 years later, it's as strong as ever. – variant Nov 28 '18 at 14:53
2

Start the cell with an apostrophe to force text interpretation:

'0502E000

Basically, this tells Excel not to parse the field as a number. Because there is an 'E' in the field, it looks like a number to Excel. The apostrophe won't actually be entered into the cell:

[a1] '0502E000
[b1] =hex2dec(a1)

Cell 'b1' will display 84074496.

  • 2
    This works when entering directly in Excel, but not with CSV file. – SBF Mar 5 '18 at 10:16
  • When opening a csv file, the apostrophe will actually be entered into the cell – Stef Jan 28 at 9:44
0

Try to load the file (data fetched from DB table) through DATA option in MS excel then simply while loading just select “Do not detect data types” under “Data Type Detection” then load , this will keep the as it as format of data and loads excel, no need for any column conversions.

0

Paste the data into a google spreadsheet. Select the column ==> Format ==> Number => Custom format => type the number of digits to which you want format to happen (ex: 10 digits = 0000000000)

  • I would like to suggest better Edit you post,, since need to add some examples!! – Rajesh S Jul 27 at 7:23
-1

With the default cell formatting, numbers with a zero in front and long numbers will automatically get modified by Excel. For example, if you type 012, it will be changed to 12.

If you format the cells as Text, then any number that you type in the cell will stay as is, and will not be modified by Excel.

However, if you paste a number from another source into a cell that is formatted as Text, and in the source there is any sort of formatting, the formatting of the cell will change from Text to General, and the number manipulation will come back.

The solution that I found was to do a paste special, and paste the number as Text. Then the cell remains with its Text formatting, and the number is not modified at all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.