0

Trying to do data recovery on an mSATA SSD from an Acer laptop... Kingston SMSR150S3/256GB

First symptom was simply Windows not booting.

Older history of the disk from when the laptop was purchased (about a year ago) was it was

1) pre-installed with a big windows partition (most of the 256 GB) and whatever other small EFI, hibernate, and/or factory-recovery partitions Acer routinely does

2) the big windows partition was shrunk to about 128 GB and a second (d:) windows partition of about 128 GB was added. (the user doesn't recall if this was done with partition magic or the windows built-in tools that do this)

Recently when the disk ceased booting, the user made a windows bootable USB and booted from it and tried to re-install windows to the c: partition. This did not work and gave the error "drive where windows is installed is locked". So we don't believe this should have affected the c: and even less likely the d: partition, BUT I don't have 100% info about every choice the user may have made when trying this re-install.

Anyway it is the d: partition from which we want to recover data. I have now hooked it up with a USB-to-SATA device with a SATA-to-mSATA adaptor onto a desktop linux machine for troubleshooting...

The strangeness now is that some tools report the whole raw disk as only 128 GB when I know it is 256 GB. Output of dmesg, /proc/partitions, fdisk, parted, gdisk follows:

# dmesg
...
[245835.332028] usb 1-4: new high-speed USB device number 5 using ehci-pci
[245835.464878] usb 1-4: New USB device found, idVendor=152d, idProduct=2338
[245835.464883] usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=5
[245835.464887] usb 1-4: Product: USB to ATA/ATAPI bridge
[245835.464890] usb 1-4: Manufacturer: JMicron
[245835.464894] usb 1-4: SerialNumber: 50026B7E33A0
[245835.465412] usb-storage 1-4:1.0: USB Mass Storage device detected
[245835.466222] scsi4 : usb-storage 1-4:1.0
[245836.464540] scsi 4:0:0:0: Direct-Access     KINGSTON  SMSR150S3256G        PQ: 0 ANSI: 5
[245836.464873] sd 4:0:0:0: Attached scsi generic sg3 type 0
[245836.471036] sd 4:0:0:0: [sdc] 250069680 512-byte logical blocks: (128 GB/119 GiB)
[245836.472167] sd 4:0:0:0: [sdc] Write Protect is off
[245836.472172] sd 4:0:0:0: [sdc] Mode Sense: 28 00 00 00
[245836.473919] sd 4:0:0:0: [sdc] No Caching mode page found
[245836.473927] sd 4:0:0:0: [sdc] Assuming drive cache: write through
[245836.478656] sd 4:0:0:0: [sdc] No Caching mode page found
[245836.478663] sd 4:0:0:0: [sdc] Assuming drive cache: write through
[245836.486808]  sdc: sdc1 sdc2 sdc3 sdc4 sdc5
[245836.491399] sd 4:0:0:0: [sdc] No Caching mode page found
[245836.491404] sd 4:0:0:0: [sdc] Assuming drive cache: write through
[245836.491409] sd 4:0:0:0: [sdc] Attached SCSI disk

# cat /proc/partitions
major minor  #blocks  name

   8        0  488386584 sda
   8        1    1951744 sda1
   8        2  242187264 sda2
   8        3  244245504 sda3
  11        0    1048575 sr0
   8       16  488386584 sdb
   8       17    1951744 sdb1
   8       18  242187264 sdb2
   8       19  244245504 sdb3
   9        0  242056000 md0
   9        1  244114240 md1
   8       32  125034840 sdc
   8       33     409600 sdc1
   8       34     307200 sdc2
   8       35     131072 sdc3
   8       36  121234432 sdc4
   8       37     358400 sdc5

# fdisk -l /dev/sdc

WARNING: GPT (GUID Partition Table) detected on '/dev/sdc'! The util fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sdc: 128.0 GB, 128035676160 bytes
256 heads, 63 sectors/track, 15505 cylinders, total 250069680 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x2831909f

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1               1  4294967295  2147483647+  ee  GPT

# parted /dev/sdc
GNU Parted 2.3
Using /dev/sdc
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) print                                                            
Error: Can't have a partition outside the disk!                           
(parted) quit           

# gdisk /dev/sdc
GPT fdisk (gdisk) version 0.8.8

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.

Warning! Secondary partition table overlaps the last partition by
250049905 blocks!
You will need to delete this partition or resize it in another utility.

Command (? for help): print
Disk /dev/sdc: 250069680 sectors, 119.2 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): BE504BB0-CF3A-4920-AD67-C6EDF9E10E94
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 250069646
Partitions will be aligned on 2048-sector boundaries
Total free space is 2014 sectors (1007.0 KiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048          821247   400.0 MiB   2700  Basic data partition
   2          821248         1435647   300.0 MiB   EF00  EFI system partition
   3         1435648         1697791   128.0 MiB   0C01  Microsoft reserved part
   4         1697792       244166655   115.6 GiB   0700  Basic data partition
   5       244166656       244883455   350.0 MiB   2700  
   6       244883456       470161407   107.4 GiB   0700  Basic data partition
   7       470163456       500119551   14.3 GiB    2700  Basic data partition

Command (? for help): quit

# mkdir d
# mount -t ntfs -o ro /dev/sdc1 d
NTFS signature is missing.
Failed to mount '/dev/sdc1': Invalid argument
The device '/dev/sdc1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

Obviously the kernel only sees partitions 1 to 5 of the 7 shown in gdisk, but it is partition 6 I need. Presumably this is related to the parted error "Error: Can't have a partition outside the disk!" and gdisk error "Warning! Secondary partition table overlaps the last partition by 250049905 blocks!". The mount command tried above gave the same error for all partitions sdc1 to 5.

Does anyone have experience with or understand the size mismatch like what I'm seeing and if so, were you able to resolve it and how? Sorry for the long post but I wanted to show what I'd investigated so far.

2
  • Do you know why Windows suddenly stopped booting? Are you sure the drive isn't just failing? Jan 8, 2015 at 18:33
  • No I don't for sure know why windows stopped booting but I assume it was some sort of NTFS filesystem corruption, where the "drive where windows is installed is locked" I mentioned above is either a cause or a symptom, so... yes I suspect it is exactly because this SSD is in the early stages of failing. This is why I'm trying to do data recovery now before it gets worse and why I need to access the 6th partition... thus need to understand why that partition seems to be beyond the end of the disk... thus need to understand why the disk seems only half its correct size. Jan 8, 2015 at 19:50

1 Answer 1

0

I have an Acer S7 with this drive. It is not actually a single 256G drive-- it is two 128G drives in a hardware raid-0 configuration.

When I have tried using this drive with a USB-to-mSATA adapter, only one of the drives is seen. Similarly, I have installed the drive in another computer, and only one of the drives is seen.

I think your best bet is to put the device back into the S7-- that is the only hardware I have found so far that recognizes both drives on the device. The S7 does work with Ubuntu and the raid-0 device is shown correctly on it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .