1

I have downloaded a file with utorrent (3.3 GB), and I have deleted it. I then recovered the file using Stellar Phoenix Windows Data Recovery Technical, but whenever i run the setup file I get this error message: This app can't run on your PC. So I thought maybe if I add the torrent file again with the same folder utorrent might re-check the files and presumably "fix" corrupted files, but utorrent acts like there are no files and downloads from the beginning.

5
  • 1
    Sounds like you should just download the file again. – Ramhound Jan 9 '15 at 11:47
  • Your "back in the download folder" trick would work with Transmission... maybe it's not named correctly – Xen2050 Jan 9 '15 at 12:02
  • @Ramhound It would take time because my connection speed is slow now. – user404266 Jan 9 '15 at 12:05
  • @Xen2050 The recovered file has the same name i didn't change it, and I tried starting the download and then replacing the contents but still nothing. – user404266 Jan 9 '15 at 12:07
  • 1
    I have no idea why this was closed as being off-topic. How weird. – Karan Apr 11 '15 at 0:17
4

The torrent client is going to identify and verify files by their hash, not by the file name.

You recovered it, and it was corrupted (no surprise). Since it's corrupted, it's not the same file, and won't produce the same hash. Hence your torrent client thinks it's a different file that is unrelated to the torrent.

0
5

it doesn't know the replacement file's there. So, what you do is start the torrent, stop it, copy the file into the destination directory, and then right click the torrent and 'force recheck'. Then it'll recheck and fetch any corrupted pieces.

2
  • 1
    This is actually the correct answer and will accomplish what the user wants to do. – Karan Apr 11 '15 at 0:16
  • Wish I knew this earlier. I just deleted the torrent lol – Lokesh Apr 15 '20 at 5:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.