1

Problem

Connected to my wireless router at home won't give me internet access.

What happened

Several days ago I was connected to the Wifi router at home and everything works like a charm. Then I closed my Thinkpad and it was send to hibernate mode. Later at the university I was also able to connect to their WPA2-Enterprise (radius-managed) Wifi.

Back at home, I wake up my laptop, fired up the Wifi connection, got an IP, but then nothing works. I have no internet connectivity.

All ping requests to public IPs and Domain Servers timed out. The Wifi router was also not reachable via ping (which may be an security feature).

Things done so far

  • Reconnected serveral times to the router
  • Deleted the credentials of the networkmanager and entered it again
  • Restarted the networkmanager using sudo service network-manager restart
  • Installed wicd and disabled networkmanager at boot by renaming it's startup files
  • Inspected rfkill to see, if there is something blocking the wireless interface
  • Booted a linux live CD to see, if theres any issue to the configuration files

Booting my windows partition and connecting to the wifi router give me internet access as usual.

System

Linux Mint 17

wlan0: Intel wifi interface

What else can I do?

  • 3
    Not a programming question. This question belongs in superuser – toddlermenot Nov 25 '14 at 17:32
1

Looking at your description, it's not very likely that any of these help, but maybe it's still worth trying.

What could be wrong?

  • Driver corrupt.
  • Connection settings corrupt.
  • DHCP corrupt.
  • DNS corrupt.
  • Wrong MTU settings (in your case unlikely, just in general).

How to check what's wrong

  • Check for error or warning messages regarding wlan0 and DHCP in /var/log files like /var/log/messages, /var/log/dmesg and /var/log/syslog.
  • Check your IP configuration using /sbin/ifconfig. The inet address of wlan0 should be present, not be link-local (169.254.*.*), and have a reasonable Mask, usually 255.255.255.0. If you dial-in on DSL or ISDN, your MTU should probably be 1492, not 1500. Example:
    wlan0     Link encap:Ethernet  HWaddr 00:01:2e:3a:58:9f
              inet addr:192.168.0.100  Bcast:192.168.0.255  Mask:255.255.255.0
              inet6 addr: fe80::201:2eff:fe3a:589f/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:106687 errors:0 dropped:0 overruns:0 frame:0
              TX packets:79673 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:107622853 (107.6 MB)  TX bytes:10363345 (10.3 MB)
  • Check routing setup using /sbin/route -n. Example:
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 wlan0
    192.168.0.0     0.0.0.0         255.255.255.0   U     1      0        0 wlan0
  • If ping 198.41.0.4 (one of the DNS root servers) succeeds but ping ietf.org fails, your DNS setup is bogus.
  • netconfig update -f fixed my DNS problems. Thanks for pointing me in the right direction! – Klinghust Feb 11 '17 at 23:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.