I have a problem with booting any live Linux distribution from a USB 3.0 flash drive (Kingston DataTraveler 100 G3 16 GB) on my on Dell Inspiron 7520 laptop running the latest BIOS version (A11).

When I do the same with USB 2.0 flash drive (Philips)—using Universal USB Installer to create bootable USB flash drive—everything works fine. I go into boot manager and choose to boot from USB and it works.

But when I do it with the USB 3.0 flash drive and go into boot manager I don’t see option to boot from that USB 3.0 flash drive but instead it’s detected a a “Diskette Drive.” And when I try to boot from it, then I will see name of Linux distribution on the screen and then it freezes.

I have tried this with several Linux distributions but no success.

  • I would dd the first 100MB of the Stick, and then try to create again. – davidbaumann Jan 9 '15 at 22:02

That seems to be a problem with xHCI support of your live system. It must include the xhci-hcd kernel module in its initramfs for proper USB3 support, otherwise you will experience a freeze during boot or other strange problems.

There has been a related bug report for Ubuntu.

| improve this answer | |

Does the USB you created boot on any other computer successfully? Might not have been created properly, see https://help.ubuntu.com/community/Installation/FromUSBStick for other creation strategies, sometimes one doesn't work when another will, same drive & iso.
I prefer the multi-boot USB method described on pendrivelinux.com (they have great windows tools too), or here on ArchWiki.

Or if it does boot ok on other computers, then it's probably a setting somewhere in your BIOS, maybe it's treating USB devices like floppys instead of hard drives. It's not a Windows 8 EFI/UEFI laptop is it? If so see: https://askubuntu.com/questions/221835/installing-ubuntu-on-a-pre-installed-windows-8-64-bit-system-uefi-supported

Or I've seen some reported problems booting from any USB3, ports might've the problem, I think the USB3 drives would work if plugged into a USB2 port...

| improve this answer | |
  • Well, I just tried to boot it on another laptop (Lenovo ThinkPad) and it worked without problems. For the BIOS, it's not Win 8 EFI/UEFI. I tried to switch from Legacy to UEFI but no effect. For the USB 2 ports, apparently Inspiron 7520 doesn't have USB 2 port ... – user1275513 Jan 10 '15 at 9:05
  • Either something mysterious in the BIOS, or it just does not like that usb... – Xen2050 Jan 10 '15 at 9:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.