1

Running a Dell 3147 11 inch 2 in 1 with Kali installed on the ssd, it doesn't detect the touchpad. I looked under xinput and it doesn't show up.

I've tried this: https://wiki.debian.org/SynapticsTouchpad too.

Anyone have any thoughts on this?

3 Answers 3

1

SOLVED! Woot!

rmmod i2c_designware_platform
rmmod i2c_designware_core

add the following into a modprobe conf file.

blacklist i2c_designware_platform
blacklist i2c_designware_core

Fixed!

2
  • It would be nice (and a better answer) if you said how this solved your issue.
    – iProgram
    Aug 9, 2015 at 17:41
  • Incorrect drivers were being loaded.
    – Joseph
    Aug 14, 2015 at 0:12
0

You can do it by some changes during boot in grub. Do it as follows:

  1. Run sudo -H gedit /etc/default/grub

  2. Locate the line

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" // or may be only ="quiet"
    

    edit it so that it looks like the following

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nopnp"
    
  3. Save and run this command in terminal: sudo update-grub

  4. Run the following commands in terminal:

     echo "blacklist i2c_hid" | sudo tee /etc/modprobe.d/i2c-hid.conf
     sudo depmod -a
     sudo update-initramfs -u
     echo "synaptics_i2c" | sudo tee -a /etc/modules
    
  5. Reboot


Thanks to pilot6 from askubuntu for the correct solution:

https://askubuntu.com/questions/592925/dell-inspiron-3551-unresponsive-touchpad

4
0

Another possible solution to help (especially for non-DELL users) is to disable the ACPI option (https://www.kernel.org/doc/html/v4.15/admin-guide/kernel-parameters.html) by adding acpi=off to the kernel boot options.

Touchpad would work after that but since ACPI is used for hardware acceleration you will probably experience some higher CPU usage.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.