0

I transferred the Thunderbird profile from a Debian Wheezy installation to a Mint 17 installation. Thunderbird recognizes the add-ins and layout preferences in the profile, but not any of the user data (email accounts, email messages, Lightning calendar entries, or address book contents).

Thunderbird Versions: The Debian system is down, so I can only work from the stored data. Its Thunderbird version was 24.3.0. That was my main system, so I had not used Thunderbird on the Mint system in probably 6 months, although it was previously working. I believe the Mint system may have had one or more Thunderbird updates installed in that time. The Mint system is currently running Thunderbird 31.3.0. Thunderbird acts as the email client for a number of POP3 accounts.

I didn't think to verify that Thunderbird was still working before transferring the profile. However, putting the original Mint profile back didn't fix the problem. That one behaves the same.

What I've Tried
The profile is supposed to be "plug-and-play". You pop it out of one system, plug it into the other, and Thunderbird is supposed to use it. I migrated from Windows to Mint to Debian in that manner with no problems. This has not worked copying the profile from Debian back to to Mint. I tried various approaches including:

  • Replacing the entire .thunderbird directory
  • Replacing the profile and profiles.ini
  • Creating a new profile and replacing its contents from the old profile
  • Doing all of the above with the profile that was in active use on Debian and with a backup of a previous one (and with the one previously in use on the Mint machine)
  • Uninstalled Thunderbird, deleted the .thunderbird directory, and reinstalled from scratch (no difference)

This Mozilla resource describes transferring components of the profile piecemeal, but the profile doesn't appear to contain anything non-essential or that would relate to the problem. The article also does not appear to be comprehensive (for example, it appears that the mail messages are contained in global-messages-db.sqlite, the only file big enough, and that isn't mentioned). I'm not familiar with the files, so moving components piecemeal would be hit-or-miss.

Numerous references on Mozilla help sites give versions of the procedure I used as the proper way to migrate the profile. Similar problems have been described on Super User in other questions, such as:

I haven't come across any posts claiming that Thunderbird V31.3 has compatibility issues with older profiles. The add-ins all loaded properly (and don't normally affect recognition of user data).

If I can't find a solution to getting an existing profile properly recognized, I can recreate the email accounts to get Thunderbird working. However, then I would still need a solution to migrating the user data from the old profiles. There is not an obvious way to do that with Thunderbird's resident tools since the profile is supposed to be plug-and-play.

1

I have transferred my data file from system to system, including new installs. Here is the trick. I keep my data in a directory k:\data\email. When i install thunderbird, i hook it up to this directory on a new profile 'Wendy'.

1   alter the shortcut to add option -P
2.  start this, the default should show the Profile manager
3.  Create a new profile, hight Wendy
4.  Point it to the email directory
    zb  k:\data\email\[random].name
5.  remove the -P icon

You could even have several different thunderbirds hooked up like this. Something similar is used for outlook too.

  • It probably would have made sense to do something like this originally--no need to move the profile around, just point to it and share. Whatever is going on, it's using portions of the profile, so finding it isn't an issue. It's not using the user data portions of it. If the issue is internal references pointing to an old location (which would defeat the plug-and-play design), I'm a day late and a dollar short for your recommendation. But if I ever get this fixed, I'll follow your advice next time. – fixer1234 Jan 10 '15 at 10:01
1

I appear to have found the depressing answer to my own question. I'll post it as a cautionary tale that may save someone else from a similar fate.

In Debian, I was backing up my home directory, which contains the Thunderbird profile, using Ark to save it as a tarball. To ensure none of the files were in use, I booted into another OS and did it from there. The process produced nice little tarballs that on cursory examination, looked complete.

It was only by digging into the profile structure and how the data is stored that I was able to identify the problem. None of the files that contained my actual Thunderbird data (emails or calendar), were included. Every backup I made was missing those few files and apparently (hopefully), nothing else. I haven't figured out why those were treated differently.

Bottom line:

  • Don't do backup by using Ark from another OS.
  • Verify that all of your critical files are included in your backup result.

Speculation: UID might have been the culprit

Both OSes have since been replaced so there is no way to verify this, but it is something to check if you are in a similar situation. I reinstalled newer versions of Mint and Debian. This time, both were on partitions of the same drive, so the first installation was visible to the second, which may have affected the issue. In the process of setting up Thunderbird so that the two could share the same profile (as in @wendy.krieger's suggestion), I discovered that, at least in the new setup, Mint and Debian used different default user IDs (UID).

I'm speculating that in the previous setup, the actual user data was associated with the UID, perhaps with different permissions than the rest of the profile, so it couldn't be seen from the other OS. In the new setup, I had to change the UID on one installation for it to see the profile on the other.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.