4

To clarify, I'm referring to entire disks disappearing, not just partitions. The PC in question is an HP Pavilion 2325DX. Both drives are variants of HGST. One is in the primary slot, the other is in an optical caddy. Partition style is GPT/UEFI. Each disk has 1 EFI partition (per disk). In Windows, the drive will be there sometimes, but sometimes gone after reboot. It only happens on the secondary drive, not the one Windows is installed on. It also seems to make no difference which slot each drive is in. My Linux install sees both drives perfectly all the time. It seems to be completely random. It doesn't happen often, just enough to annoy, and is hard to get it back again. This has perplexed me for over 2 months.

What I've tried:
1. Called HP, won't help unless I pay a hefty fee and won't give any info, PC is a gift and no longer warrantied.
2. Called HGST, they say they've never heard of such an issue, no firmware updates available, rep never called me back.
3. Swapped the drives into the other slot, issue went away for awhile then returned.
4. Installed all Windows Updates and latest drivers.
5. Tried Win 7/10, same issue.
6. Ran SMART/diagnostics tests, drives are relatively new and came up clean.
7. Put both disks into an external caddy, they read fine from Windows/Linux, and from friends' PCs.
8. Tryed varying partitions sizes of less than/more than 1TB, seems to have no effect.
9. Downgrading/Updating BIOS, no effect

I'm thoroughly confused in regards to what could be causing the issue and don't know where to start looking, new optical caddy is cheapest option but not guaranteed to work. PC is otherwise satisfactory in all other respects.

Thanks in advance!

  • Does the hard drive spin down / power of then it gets disconnected? Dirty/broken connectors? – Xen2050 Jan 10 '15 at 8:52
  • It is already not recognized by Windows as soon as I log in. I've never paid attention to whether it spins down/powers off while logged, but it has never disappeared while already logged in or while actively using it. Neither Disk Management nor diskpart (CMD) can see it, or 3rd party software. It is visible in the BIOS and Linux never fails to see it.What is the best chemical solvent for cleaning connectors that won't damage the drive? Or perhaps just a soft linen/cotton cloth is better? – Enigma83 Jan 10 '15 at 9:16
  • I'm seriously thinking on installing Arch Linux on one of the drives, and then forcing myself to use it exclusively for at least a few months. The other drive could be dedicated to Linux too. I've been meaning to get serious about it for awhile now and this is an extreme way to go. But I'm a gamer and that holds me back in this regard. I'm still curious to know what is causing this, and the Linux-only approach wouldn't be a real answer anyway. – Enigma83 Jan 10 '15 at 9:50
  • More info: When 7 was installed on either of the HGST drives, an Eject device would appear in the lower right of the screen in the Taskbar, with a notification mouse over that listed C:. This would, of course, be the volume Windows is installed onto. Upon clicking it, I got the expected message that the volume/drive was in use. Windows 8.1 doesn't show this. And for some volumes in fixed internal disks Windows will ask me what I want to do with removable drives after assigning a letter. I also am wondering whether disabling/enabling write-caching may have an effect. – Enigma83 Jan 12 '15 at 9:43
  • An eject icon would suggest a removable device. Is this 2nd drive perhaps inserted instead of a cd-rom drive? – R-D Jan 12 '15 at 9:56
4
+25

Another idea : Sometimes the problem is with the power supply. There are two cases :

  1. The secondary hard disk is connected to a power cable which is shared with another device.
    If the other device draws a varying amount of current, it might not let the disk start up fast enough to be counted as up and running by Windows. The allowed startup times vary between different operating systems.

  2. The Power Supply itself is barely enough for the computer and is sometimes not enough.
    Especially if some device sometimes draws more power than it is supposed to.

The first case can be verified by giving the secondary hard disk its own unshared power cable. The second case needs careful calculation of the power needs, remembering that the Power Supply might not be capable of really delivering every last Watt in its specification.

  • The secondary hard disk is connected via a caddy, and that caddy uses the connector that an optical drive would normally use. I'm fairly certain it's not shared with anything else. The laptop is using the OEM power supply/battery that HP included with it at date of manufacturing. Are you suggesting a new power supply that can provide more power might solve this? How can I determine whether or not the current supply is able to provide enough watts/amperage to power all components inside the laptop? – Enigma83 Jan 12 '15 at 9:51
  • Try to disconnect every possible device that draws power and see if that helps. There are also online power calculators that can give you an idea whether you approach the limit of the PSU (but note that for example a 450W PSU might not in reality be able to deliver more than 400W). – harrymc Jan 12 '15 at 10:32
  • All devices that draw power are located inside the laptop, caddy included. By disconnecting the caddy drive, surely the issue would be solved, but then I wouldn't be able to test it. I can, however, unplug things like USB mice, USB HDDs/thumbdrives, etc and see what happens. My guess is that the issue will remain. – Enigma83 Jan 12 '15 at 10:39
  • It says? If the laptop has integrated graphics and a video card, you might be able to disconnect the card, in addition to USB. – harrymc Jan 12 '15 at 11:00
  • (Continued from above, couldn't finish editing in time): Input, 100-240V, 1.7A, 50-60Hz. Output: 19.5V, 3.33A, 65W. I assume only output is relevant. On the battery it says: 4200mAh, 10.8V, 47Wh. – Enigma83 Jan 12 '15 at 11:02
2
  1. Insufficient power on startup. Possible as ODD usually requires more power to work, but less or same while spinning up as HDD. But make sure - what is the nominal power consumption for the hdd in the caddy? Usual are 0.5 A/1.0 peak for hdd. Try disabling all devices - wifi for example. LAN, especially if configured wit network boot (PXE).. I would rule this out, though - you say it's always secondary drive that's missing then it's definitely software problem. And yes, that would include UEFI.

  2. No matter which slot, windows missing secondary one. I'm not sure on Win8.1, but is there a way to designate drive as "permanent", as opposed to "removable"? It would normally have no issue on reboot (just on wake), but this is UEFI...

  3. Power options in Windows may have something to do in connection to "removable media". Again: no issue on boot/reboot, just on wake.

  4. SATA is designed as hot-plug compatible. You can disconnect and reconnect drives while system is powered up. Will Windows recognize it after that?

  5. Windows 8 likes UEFI very much and when those two get together, they like very much to be ran in "Secure Mode". In my Dell days this option was responsible for lots of issues on it's own. Disable/Enable does the trick?

  6. UEFI has it's own quirks. Sometimes going from UEFI to Legacy mode, reboot, switching back to UEFI and rebooting again clears a lot of issues with HDD recognition on start-up...

  • @ AcePL: See my discussion (above) with Harry in regards to power requirements. I believe he is closest to the mark. I still believe this is a Windows OS (software) issue, insufficient power, or both. I'm not aware of a way to mark drive as permanent, you would think Windows is smart enough to know the difference. I don't use sleep/hibernation at all, non-issue. I will check to see what happens when hotplugging. Windows boots in UEFI mode but secure boot is off, causes huge headaches with booting Linux and USBs. I will try to switch from UEFI to legacy CSM. This could just be an HP quirk. – Enigma83 Jan 12 '15 at 14:34
  • Power issues... Yes, but: this should NOT happen to both drives irrespective of slot. In this case this would be ALWAYS secondary drive (hardware-wise, that is one in caddy). Also, ODD is power intensive on a spin-up and on full speed. Hdd is usually lower on power consumption. If the "Secure boot" is disabled, this may be it... I would point to that, especially if secondary drive has other OS on it. – AcePL Jan 12 '15 at 15:03
  • Assuming, of course, I understand you correctly when you write that always secondary (software-wise speaking) goes MIA. And by that we mean non-OS drive? And harrymc speaks - or it looks like to me - about desktop? it is very rare to be able to swap cables in a laptop? I know models, but still... it requires custom manufactured parts. I worked on laptops with 2 or 3 dedicated bays for HDD (Top line DELLS support up to 5 HDDs (2 bays x2 HDDs + ODD). – AcePL Jan 12 '15 at 15:10
  • When I say secondary, I'm always referring to the drive Windows is NOT installed to, whether that be the caddy slot or primary master slot. Both drives have dropped in both slots, but never the one Windows is booting from, regardless of location. I'll agree that the HDD in the caddy slot would probably need more power at boot-time, which (according to Harry) is when Windows would TRY to initialize all internal devices at the same time. I fail to see how activating Secure Boot would help, I view it as a major pain in the.....you know. – Enigma83 Jan 12 '15 at 15:18
  • Sorry for flooding - edit timeout 5 mins is restrictive for me ;) OK, my bad. If your laptop has box-specs, then your 65W AC Adapter is seriously underpowered for 17.3 inch laptop with AMD and discrete GPU. How do you even run it on that small power supply? If that's the case then harrymc is onto something. However, no issues in Linux would indicate Windows issue, not power anyway... 65W is not enough, period. Not: "not enough for Windows"... I would say 90W is minimum, suggested 120W – AcePL Jan 12 '15 at 15:19
1

Hmmm, only gone after starting up... I had a drive that would take a little too long to "start up" sometimes, and the computer would start without it, like the drive wasn't connected. Would have to go into BIOS & then soft reboot and then it would see the drive as usual. Maybe a longer delay when starting might help?

Or when doing a "soft reboot" is the drive ever gone, or is it always there? Soft reboot being a software restart/reboot, like CTRL+ALT+DEL, keeping the power on so the drives never power off. Could give more clues if it always shows up after a soft reboot, or is always gone...

--- After reading comments about the drive is always there in BIOS & linux, but not always visible in Windows... looks like only windows hates that drive... I guess the "standard windows advice" couldn't hurt: reboot, update, reboot

So far it's a mysterious & hard-to-reproduce problem (the worst kind).

  • You might want to try using linux for a few days to see if it really never happens with Linux. If it does start happening with linux too that could indicate a hardware problem.

  • And search hard drive manufacturer's website for updated software / drivers that might not automatically enter windows. Maybe a firmware update for the drive. The rep on the phone not calling back does not inspire confidence in them.

    • Maybe even a recent update that could have started this problem, if it didn't occur before some update then undoing the update / rolling back the software could make it go away?
  • When the drive is present, it never goes away until after a reboot/shutdown. No sudden disconnects while logged in. And if it isn't present at boot/login, then it never appears. It is always present in the BIOS. I've waited as long as 30 mins but it never shows up. Not even in software like AIDA64. It is as if Windows hasn't been made aware of the drive's presence despite being physically connected. Or something is causing it to be ignored. – Enigma83 Jan 10 '15 at 10:03
  • In response to your edit, Windows is already fully updated, I update as soon as Windows Update pushes out new updates. As for drivers, I routinely check for new ones each month, and they're all installed.I've also installed the most recent motherboard/chipset/SATA/video drivers from AMD's website. I deeply suspect this is a Windows-only issue rather than a hardware/firmware issue. – Enigma83 Jan 11 '15 at 6:13
  • Can you clarify what you mean by "soft reboot"? I'm guessing you mean regular reboot rather than a full shutdown. I haven't noticed a difference either way. – Enigma83 Jan 12 '15 at 14:58
  • Soft reboot meant doing a software restart/reboot, like CTRL+ALT+DEL, keeping the power on so the drives never power off. Could give more clues if it always shows up after a soft reboot, or is always gone... I'll edit in a little more info, updates & stuff – Xen2050 Jan 12 '15 at 15:20
  • I'm going to try mainly running Arch for a few days, studying commands and testing games in WINE, occasionally rebooting into 8.1 to play DayZ/Arma 2 online. That should appease me for awhile while I keep an eye on the drives. I have checked HGST's site for drivers/firmware, nothing. The rep said all necessary drivers are built into Windows. As for other drivers, it doesn't happen often that new ones are released. This is a 2012 laptop that shipped with Windows 8. And updates, usually just for Windows Defender, rarely do security updates appear. – Enigma83 Jan 12 '15 at 16:12
0

A couple of ideas:

  1. In Windows Disk Management, see if the missing drive is there, but just with no drive letter. If so, assign a new drive letter and see if the operating system now recognizes it.
  2. Have you tried a different hard drive in the caddy?
  • The missing drive doesn't appear at all. Keep in mind that you can only assign letters to volumes/partitions, not drives. I have tried swapping both drives into the slot that the other was previously in. One is 1TB, the other is 1.5TB. I'll have to see if I can find other drives to test with. – Enigma83 Jan 10 '15 at 21:53
  • I just found a SATA HDD sitting around in a box. It's around 2 years old, Seagate 500GB, haven't used it in a few years. Time to test. It might take awhile, since the disappearances are random. – Enigma83 Jan 11 '15 at 1:24
  • Just figured I would add more info: I haven't had any success in getting the Seagate drive (see my comment below) to disappear. So far it has remained visible and accessible. Windows isn't installed to the Seagate, the drive Windows is on has never failed to boot. Cleaning both HGSTs doesn't seem to make a difference, the issue above still occurs. As for the bounty, I doubt a conclusive answer will be found within a month, and so I will award it to the user whose information I feel is the most relevant to the end of finding a solution. – Enigma83 Jan 12 '15 at 9:04
0

My Linux install sees both drives perfectly all the time.

You mention your problem exists in Windows, but not Linux. This would indicate a software problem, not a hardware problem.

  1. Installed all Windows Updates and latest drivers.

Typically people update their Windows drivers one of two ways: Windows Update, or the computer manufacturer (in this case HP). In both cases, it appears neither of these channels are providing an updated AHCI driver. I would go so far as to assume that the AHCI driver you're using is the generic Microsoft one provided with the operating system.

Your AHCI controller is made by AMD. To download a driver for it, go to the Driver and Support page for Windows 8.1 and click "Optional Downloads". You will notice the package available for download there mentions including an AHCI driver.

  • I rarely install drivers from Windows Update, I usually use it only as a point of reference to determine what drivers are missing, and only taking a driver from WU if I can't find it elsewhere. Just recently I trusted WU to install my Ralink Bluetooth driver, which caused a BSOD boot loop upon rebooting. I was able to purge it, then checked Event Viewer, and sure enough, it was the culprit. I also don't install OEM drivers often either, instead opting to go straight to the component manufacturer for a more recent version. If that works (usually it does) then I stick with it, if not, then OEM. – Enigma83 Jan 12 '15 at 16:59
  • I also already have the driver you linked installed, it's for the motherboard/chipset/SATA/USB. I keep all drivers locally stored on an external drive and check about once a month for newer ones. This being a laptop manufactured in 2012, it no longer receives frequent driver updates. HP is particularly negligent when it comes to pushing out the newest drivers, they're frequently many months or well over a year behind. But at least it's not a dinosaur. – Enigma83 Jan 12 '15 at 17:02
  • @Enigma83 I'm glad to hear you already tried this option. I will leave this answer here as it might help others with a similar problem. – Jason Jan 12 '15 at 17:04

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.