11

I've been trying to boot a Windows 7 (yup) USB in this laptop, but neither using UEFI nor Legacy boot would work. In UEFI, always boot the HD even if it's last in priority list. In Legacy boot, nothing works. My USB is partitioned as a boot CD (yes, that's a real booting device, if you doubt it), but that laptop doesn't say so.

What should I do next? Is there any way for booting from USB or should the HDD be changed?

  • Check in bios there may be an option for boot from external device, also check your bootable USB. – A. Prasad Jan 10 '15 at 10:52
  • Checked. That's only the priority list. Strange thing is, on setting the Legacy boot, it does detect (the BIOS) my USB drive, but when I boot up, meh, seems to forget that there's a USB. It's weird. – Suzamax Jan 10 '15 at 10:55
24

I do not know if you have finally installed Windows 7, but I had the same issue and I resolved it this way:

  1. Open the notebook and press quickly F2 to enter the BIOS.
  2. Under the MAIN menu, enable the F12 Boot Menu option.
  3. Under the BOOT menu, select Legacy boot and press F10 Save & Exit.
  4. While the notebook is rebooting, press F2 again to enter the BIOS.
  5. Under the BOOT menu, select as your first boot option the USB HDD stick (your USB stick).
  6. Press F10 Save & Exit.

or

After you rebooted at step 3, you can press F12 and select from there your boot option (USB).

It worked for me, I found out that the problem was the USB 3 port. Maybe if I put it in the USB 2 ports I wouldn't need all these steps.

  • 3
    The Legacy part did it for me. When it was on UEFI (boot) I could only see windows boot manager (I had win 10 but needed to reinstall it). – dingo_d Aug 30 '15 at 17:31
  • Sadly, that computer wasn't mine so I couldn't installed Windows in the laptop. Anyways, I hope your answer could've helped the one who install it, if it had been installed by now... – Suzamax Jan 11 '16 at 7:44
  • Thanks Thanoshld. I had the same issue for Acer Aspire ES1-521 Notebook. and you answer helped me. It had worked for me. – shashaDenovo Oct 10 '16 at 5:09
  • 1
    Legacy also did it for me. I had set all the USB boot options in the bios (HDD, FDD, CD) to the first three of the boot list but it wouldn't recognize a USB drive made with the official Microsoft tool. Thanks! – Anders Dec 11 '16 at 5:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.