0

I am installing the CUDA toolkit and nVidia driver on a machine with GTX980s and CentOS 6.6. According to nVidia I need a different CUDA toolkit (6.5-19 instead of 6.5-14) than normally offered on their developer website. This version of the toolkit installs driver version 340.19 (which makes no sense since 340.22 added GTX980 support). Now when I install the the driver from CUDA the cards are not recognized apparently (nvidia-smi complains that no driver is running). I tried installing the newest driver available (340.65), but that appears to be incompatible with the version provided by CUDA. I have tried installing the driver first and then CUDA. And still have the same incompatibility problem for the driver from CUDA vs. the one installed.

Is there a solution to get around this?

Thanks

Solution:

Installing just the CUDA toolkit without the driver and installing the correct driver.

  • Please post the solution you found as answer rather than editing it into your question. This will help anybody who comes across this question easily recognize that it has been solved. Thanks. – Excellll Mar 30 '15 at 18:45
0

I also had the same kind of issue with CentOS. Apparently there is an issue with the kernel version support for CUDA-6.5 with CentOS 6.6. Have you tried in combination with nouveau and CUDA 6.5??

0

I found work around by installing the driver separate from CUDA6.5. To do so, I installed CUDA using the package from the website rather than the nvidia RHEL repo. This gives you the option not to install the driver. With driver version 343.36 and CUDA release 6.5, V6.5.16 it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.