1

i have a micro sd card (class 10) i bought. i tried using it with my camera and it worked, also my phone.

but if i connect my camera to my pc (windows 7) it won't work: it creates a new drive(Removeable Disk) but if i double click it says please insert disk.

so i tried using the camera with a different card i had and it worked.

its just the combination of the sdcard + pc

how can i fix this?

5
  • What was the "file system" that the device formatted the card with? Where was the card originally formatted? and what file system does it prefer to format a card with?
    – Psycogeek
    Commented Jan 11, 2015 at 1:25
  • i cant see it on pc, only on android. but its either fat32 or exfat
    – Erez
    Commented Jan 11, 2015 at 1:46
  • i double checked. its fat32
    – Erez
    Commented Jan 11, 2015 at 2:41
  • I wonder if it is a partitioning issue? windows does not handle partitions on flash cards/sticks well? (which does not explain why there is a problem when connecting with the camera) If there are tricks used in the card or the method of formatting/layout on the card that windows goes brain dead on. What is the size of the card?
    – Psycogeek
    Commented Jan 11, 2015 at 2:51
  • 32gb. i now tried formatting it on my phone using an app. still no change
    – Erez
    Commented Jan 11, 2015 at 2:55

1 Answer 1

1

You access the camera using USB, right? Try mounting the card externally using a card reader.

1
  • 1
    it doesn't work as a "mass storage". but i can put it on my phone and connect it as a "media device" which works but is a lot of effort
    – Erez
    Commented Jan 11, 2015 at 14:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .