0

I have ASRock Fatal1ty 990fx Killer that has the Atheros AR8161 NIC (branded as Killer LAN). I'm direct connecting to a Motorola SurfBoard 6141 with Cat5e cabling. My Windows 7 Professional is set to auto-negotiation and I'm only getting 100Mbps connection. With the same cable plugged into my MacBook Pro from the modem, I achieve a full Gigabit connection. There seems to be many issues regarding this across the web and I'm looking for a solution that will solve my issue.

I've tried both the Killer LAN driver and the driver directly from Qualcomm.

1
  • Could be a driver problem on Win 7. Aside from the fact that you don't really get 1GBit throughput on any cable system anyway. I have pretty good access and I used the same Cable Modem, and about the max that I have seen on any website is 70 MBit. Thus a 100 MBit connection should do ok.
    – mdpc
    Jan 11, 2015 at 6:45

1 Answer 1

0

If I understand things correctly:
Both computer network card and cable modem supports 1 Gbps speed.
You have tried with two different drivers for the network card.
When testing the cable on your Mac it achieves a 1 Gbps connection.

It could be that the cable is of poor quality and just barely manages the speed, making it so that the Mac accepts for 1 Gbps speed and the Win7 machine rejects it, falling back on 100 Mbps. Try a diffrent cable to be sure.

A workaround for that should be to change the adapter settings/config and change from auto-negotiation to force "1Gbps Full Duplex" (or whatever they call it). Note, that if the cable really is the problem this may cause issues with lost packets.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.