2

enter image description here On "PC3", Windows name resolution fails like this.

ping PC1

Ping request could not find host PC1. Please...

ping 192.168.0.2

Reply from 192.168.0.2: bytes=32 time<1ms TTL=128

But if I remove "Router 2" and connect the line from "Router 1" directly to "PC3", I get

ping PC1

Reply from 192.168.0.2: bytes=32 time<1ms TTL=128

What could be the cause? I disabled the firewall on PC1, but it did not solve the problem. "Router 1" has an option "DHCP RESERVATION" and I have put an entry for it like the following, but it did not solve the problem.

Computer Name | IP Address | MAC Address

"PC1" | "192.168.0.2" | "PC1's MAC address"

Windows networking finds "PC1", but without name resolution, the web server running on PC1 is not accessible by the computer name. This is a home network, so none of the PCs are joined to a domain. I would like to avoid adding a manual entry for PC1 to PC3's HOST file.

===================== Addendum 1===================

When connected to "Router 2" (not all of them are listed)

192.168.0.4 192.168.0.1 DNS Standard query A PC1.Workgroup

192.168.0.1 192.168.0.4 DNS Standard query response No such name

192.168.0.4 192.168.0.255 NBNS Name query NB PC1<00>

192.168.0.4 224.0.0.252 LLMNR Standard query A PC1 and AAAA PC1

(No response from 192.168.0.2 hereafter)

When directly connected to "Router 1" (not all of them are listed)

192.168.0.4 192.168.0.255 NBNS Name query NB PC1<00>

192.168.0.4 224.0.0.252 LLMNR Standard query A PC1 and AAAA PC1

MAC address Broadcast ARP Who has 192.168.0.4? Tell 192.168.0.2 and its response

192.168.0.2 192.168.0.4 LLMNR Standard query response A 192.168.0.2

In both cases, the Name query content was the same other than the Transaction ID.

  • You mention that router 2 is in "hub mode"? I take it that means you've disabled DHCP/firewall and any other routing functionality and are connecting to it via one of the switch ports (and not the WAN port)? Do netbios transactions fail both ways when you have the switch (router 2) set up? if you take pcaps on both sides (pc1 and pc3) what is different between both setups? – MaQleod Jan 11 '15 at 22:46
  • "Router 2" has built-in "hub mode". In the configuration page, I can choose between "hub mode" and "router mode". It seems if "hub mode" is chosen, it works like a switching hub. "ping PC3" on "PC1" works. – Damn Vegetables Jan 12 '15 at 2:02
  • I installed WireShark and read the raw protocol data. The Name Query packet was the same (except the Transaction ID), but when connected to "Router 2", I could not see any response from "PC1". I have added the digest of the packets to the question. – Damn Vegetables Jan 12 '15 at 3:21
  • Seems it isn't using NetBios, but LLMNR, which is preferred as it is the successor to NetBios. I find it interesting that it chooses to do a DNS request first when connected through router 2. That plus the lack of the ARP request may say something about how it sees itself in the topography. I suspect "hub mode" isn't as close to a switching hub as it sounds. Do you just have a standard 4 port switch that you can plug in and test with? – MaQleod Jan 12 '15 at 4:04
1

The cause and solution can be found here.

Cause

With KB3161949 update Microsoft changed the way server is allowed to respond to NetBIOS queries and prevents responses to outside subnets

Solution

To overcome this you can either:
1. uninstall security update KB3161949 from your server (not recommended)
2. update registry parameter for NetBT with Dword AllowNBToInternet set to 1 and reboot the server

  • by cmd:

reg add "HKLM\System\CurrentControlSet\Services\NetBT\Parameters" /v "AllowNBToInternet" /t REG_DWORD /d 1 /f

  • by PowerShell:

Set-ItemProperty -Path HKLM:\SYSTEM\CurrentControlSet\Services\NetBT\Parameters -Name AllowNBToInternet -Type DWord -Value 1

  • After 3 years I had given up that configuration because of that.... I will try that when I move to a new place and set up the routers. – Damn Vegetables Jun 5 '18 at 16:54

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.