I have an external hard drive which has been formatted for linux. And I now only has a MacBook Pro, how can I read the data on the linux formatted external hard drive?

I have tried installed Virtual Box and install an ubuntu machine in it. But when I put in my external hard drive, I go to 'computer', it does not see that external hard drive. Any one has better idea?

Thank you.

3 Answers 3


Without further information I'll assume it's ext2 or ext3. You can use MacFUSE with fuse-ext2 to access these partitions with ease.


sudo mount -t fuse-ext2 /dev/disk0s2 /mnt
  • Thanks. I have tried you idea. I get this error: FUSE-EXT2 could not mount /dev/disk0s2 at /mnt because the following problem occurred: fuse-ext2: enter [do_probe (../../fuse-ext2/do_probe.c:30)] fuse-ext2: enter while trying to open /dev/disk0s2 [do_probe (../../fuse-ext2/do_probe.c:34)] fuse-ext2: Probe failed [main (../../fuse-ext2/fuse-ext2.c:337)]
    – hap497
    Dec 23, 2009 at 3:31
  • 1
    That was just an example. I don't know which disk you are trying to mount. disk0s2 is the second slice of the first disk. Replace it with the location of your Linux disk.
    – user1931
    Dec 23, 2009 at 7:53
  • diskutil list will show you the attached disks.
    – Dan Pritts
    Aug 11, 2015 at 14:44

There are many filesystems that Linux supports. You shall plug your hard drive into a Linux box and do a little investigation to find out what kind of filesystems it contains.

You can also google up a list of filesystems supported by Linux and try them one by one when mounting manually. To exclude potential damage, just try mounting the filesystems read-only (use the correct command line option for mount, that'll be "-o ro").


Just wanted to make a note about this.

If you're on Snow Leopard and tried to install ext2fsx (which will result in failure), attempting to use ext2-fuse may result in:

fuse-ext2: version:'0.0.7', fuse_version:'27' [main (../../fuse-ext2/fuse-ext2.c:324)]
fuse-ext2: enter [do_probe (../../fuse-ext2/do_probe.c:30)]
fuse-ext2: Error while trying to open /dev/disk1s1 (rc=16) [do_probe (../../fuse-ext2/do_probe.c:34)]
fuse-ext2: Probe failed [main (../../fuse-ext2/fuse-ext2.c:340)]

Although the installer of ext2fsx failed, it may not roll back successfully. A call to sudo dmesg | tail might show something similar after pluging in the device:

ext2fs: registering sysctl 'e2fs' with OID 61267
ext2fs: registering sysctl 'dircheck' with OID 1
ext2fs: registering sysctl 'lookcacheinval' with OID 2
ext2fs: reading superblock from block 2, with size 1024 and offset 0
ext2fs: dir_index feature detected - write support disabled
EXT2-fs DEBUG (/Users/brian/Projects/Sourceforge/ext2tiger/src/gnu/ext2fs/ext2_vfsops.c, 1465): ext2_vget:Returning Error! (2)
EXT2-fs DEBUG (/Users/brian/Projects/Sourceforge/ext2tiger/src/gnu/ext2fs/ext2_vfsops.c, 1663): ext2_root:Returning Error! (2)

Notice that even though ext2fsx failed, it's still attempting to access the drive.

To fix this, run ext2fsx's uninstall script. You can then use ext2-fuse without any hassle.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .