2

I'm receiving following message inside of Event Log window whenever I'm launching Android Studio:

OpenJDK shows intermittent performance and UI issues. We recommend using the Oracle JRE/JDK

In order to run Android Studio, I was asked to install Java 1.7+, which I did:

[alexus@wcmisdlin02 ~]$ rpm -q jdk1.8.0_25-1.8.0_25-fcs
jdk1.8.0_25-1.8.0_25-fcs.x86_64
[alexus@wcmisdlin02 ~]$ 

I'm using following:

[alexus@wcmisdlin02 ~]$ cat /etc/redhat-release 
CentOS Linux release 7.0.1406 (Core) 
[alexus@wcmisdlin02 ~]$ uname -a
Linux wcmisdlin02.XXX.org 3.10.0-123.13.2.el7.x86_64 #1 SMP Thu Dec 18 14:09:13 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
[alexus@wcmisdlin02 ~]$ 

How can I either force or "re point" Android Studio to use Oracle JDK instead of OpenJDK?

0

The recommended way is to set the STUDIO_JDK environment variable before launching.

export STUDIO_JDK=/usr/lib/jvm/jdk1.8.0_25-1.8.0_25-fcs.x86_64
./studio.sh

replacing /usr/lib/jvm/jdk1.8.0_25-1.8.0_25-fcs.x86_64 with the path of your jdk installation

Reference: Configuring Android Studio: IDE & VM Options, JDK, etc - Android Tools Project Site

  • Hows about some upvote love? – Xiao Feb 4 '15 at 22:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.