23

Apparently Chrome updated again and decided to put my name in the top right corner. I don't want to uninstall my "profile" (synched with my Google account)—is there a way to remove the name from the top corner (or to replace it with an image) without damaging my sync settings?

Update: Now appears as a profile icon in Chrome 69

  • 5
    This is the most annoying new feature ever introduced in Chrome. I acknowledge that it is useful for people with multiple accounts, but for the large majority of users it is just an annoying and useless widget in the title bar. I hope that Google will never remove the flag to disable this feature. – Wizard79 Jan 17 '15 at 15:26
  • Google force-enables that avatar button after Chrome 44. Here is the change request to "bringing back user control to disable avatar button": code.google.com/p/chromium/issues/detail?id=513899 Chrome devs are closing all the requests to bring back this user control as: "Wont Fix". Google is taking a page from the book of Microsoft. It looks like Google and Chrome is eating from the apple of the tree of good vs evil, figuring out that they too have become Gods, and the users can cry all they want, the Avatar button stays, if you don't like that, then don't use Chrome. end=near – Eric Leschinski Dec 17 '15 at 0:45
  • I actually preferred to have my name as it is hard to tell the difference between my work and home account by icon. Is there a flag to bring back the name from the top right corner now that it is gone? I am on 69. (He he, can't please everybody) – Joshua Sep 14 '18 at 11:26

10 Answers 10

13

I used to workaround SO's comment limitation with the \u200b trick. Seems that it works just fine with Chrome's avatar menu.

  • Open up devtools (⋮ [More Options] > More Tools > Developer Tools)
  • On the Console tab, run copy('\u200b') to copy a blank space to your clipboard
  • Click on the avatar menu, edit the name, paste from the clipboard

Done.

Gone... long gone...

  • 3
    This is currently the best solution since the option to remove the menu altogether was removed. Thanks! – Wolf Dec 8 '16 at 15:45
18

The following instructions no longer disables the avatar menu in Chrome 44 (released July 2015). Setting the flag to Disabled no longer disables the avatar menu.

To disable, go to the corresponding Chrome setting with the URL below and change the option to Disabled

chrome://flags/#enable-new-avatar-menu
  • 3
    I don't know why you got downvoted. It works for me. – Florian Jan 13 '15 at 19:12
  • 1
    I've tried this and it worked. – BernardoLima Jan 14 '15 at 0:43
  • 8
    No longer working in Chrome 44 (released July 2015)... setting the flag to Disabled no longer disables the avatar menu :( – degenerate Jul 21 '15 at 21:17
  • 2
    For chrome 44, add --disable-new-avatar-menu when startich chrome. techdows.com/2015/06/chrome-44-disable-user-menu.html – Patrik Jul 23 '15 at 21:04
  • Flag not there in v63 – boardtc Feb 7 '18 at 12:07
9

Here is an easy workaround that works with any version of Chrome (I'm using 49.0.2623.87 at the time of writing). It does not totally remove the name, but it makes it totally invisible with a minimal footprint on the title bar.

  • Click on the avatar name in the title bar. A popup appears containing your avatar picture and your name.
  • Click on the picture, and the "ManageProfile" window should appear in Chrome
  • In the "Name" entry box, simply type a dot '.' and hit ENTER to validate
  • Now, your name is replaced by a single dot in the title bar, but all your account parameters (bookmarks, extensions, and so on) are still working

Even better: Chrome does not allow you to use a whitespace as your name, but any Unicode character may be used instead. I suggest to use "Soft Hyphen" (U+00AD) which is totally invisible. I don't know any easy way to enter this character from a keyboard, but simply go to "unicode-table.com" and copy-paste the U+00AD character...

  • 1
    Stupid, but works :) 👍 – BoD Apr 9 '16 at 8:23
  • 1
    I am having hard times getting the soft hypen to clipboard :/ – krizajb May 29 '16 at 13:08
  • The (now tiny) tab doesn't go away, but it's better than nothing. My original problem was that TeamViewer adds a <--> tab to all windows, for easy sharing of that window with others. Unfortunately this was placed right on top of the name tab in Chrome. Not cool. While they still overlap a bit now, it's much easier to hit the TeamViewer tab, without hitting the name tab instead. Excellent :-D – Gertsen May 30 '16 at 11:15
  • 3
    Direct link may help unicode-table.com/en/#00AD ;-) – BG Bruno Jun 12 '16 at 23:16
1

The following instructions do not remove the avatar button in Chrome 44 and after:

For Chrome 43 and prior:

  1. Exit from Chrome browser.

  2. Right click on its desktop shortcut and select ‘Properties’

  3. In the target field, after Chrome.exe add the below switch after giving space and click ‘Apply’

--disable-new-avatar-menu

Tip: You better pin that shortcut to taskbar to launch it quickly. Hold ‘Ctrl’ button, right click on the shortcut and select ‘Pin to taskbar’.

  1. If you launch Chrome from taskbar, ensure this: right click on Chrome icon on taskbar, hover over Chrome, right click on it >Properties and check there is the switch we’ve added in target field.

UPDATE: Whole Target field in the Properties dialog should be as below (could be different if you’re using 64-bit Windows)

"C:\Program Files\Google\Chrome\Application\chrome.exe"--disable-new-avatar-menu

We’ve tested and it worked, let us know if you’ve any doubts in the comments.

0

Setting > People > Then select your account > Edit > Then erase your name or simply put any character instead of your name.

0

Try this :)

You just need to click on the name on right corner of the browser.

  1. It gives you pop-up window enter image description here

  2. Now click on remove this person. Google will save your synchronization, again when you try to install new chrome you have to sign in on chrome with the same account and you will get the same synchronized data.(Bookmarks, Favorite, etc.)

  • This doesn't solves the problem: the new avatar menu will still be enabled. The only true solution is to disable the flag, as in this answer – Wizard79 Jan 17 '15 at 15:24
  • You can change your display name if you click on it under the picture. – Oleg Vaskevich Jul 5 '15 at 22:27
0

Update to Version 48.

In Chrome Version 48, it is removed. Instead, there is icon that you can click, which opens a drop down, and the name is in there.

At least, the name is not visible until clicked, and it is not visible in screen copies.

  • 3
    Nope, you're just not logged in. – Lloeki Jan 28 '16 at 20:37
0

Screenshot

You can just enter this code (in the screenshot) in place of your name from the Character Map: Combining Grapheme Joiner U+034F

This is for Windows 10 1709

Posted 10.21.2017

-1

Go to chrome://settings/ Disconnect the user in the "Sign in" section.

Also you can click the image in the top right by clicking on your profile image and it will allow you to update your name and image.

-1

Enter this is address bar:

chrome://flags/#enable-new-profile-management

Then select Disabled from drop down menu.

  • Google has disabled this control feature in Chrome 44. – Eric Leschinski Dec 17 '15 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.