I run an application that needs the Telephony service to run. Despite having the startup type set to Automatic, I still need to start it manually after it boots.
I created a bat file with "net start TapiSrv", as a workaround, but that is simply treating a symptom, not a cure. Any reason why a service won't start despite being set to Automatic? All the other services I need seem to start fine.

  • 1
    dependencies all running? Plug&Play, RPC, DCOM server process launcher, RPC Endpoint Manager?
    – Tetsujin
    Jan 13, 2015 at 14:42
  • It might be that during bootup the services that it needs to start up are not yet running, you can try setting it to "Delayed" startup and see if that helps you.
    – Optichip
    Jan 13, 2015 at 14:43
  • @Tetsujin I believe to as I can start it without problem with a bat file. Optichip, I thought I tried that, but I'll double check. I can't reboot again until tonight to test unfortunately.
    – pooter03
    Jan 13, 2015 at 15:05
  • As a work around you could make a wscript or batch script with a sleep function that run's net start TapiSrv you could then add this script to the boot/startup menu.
    – Tim Jonas
    Jan 13, 2015 at 15:13
  • As Tetsujin states, you may need to set Dependencies in Services, so it will wait for other required to start. Jan 13, 2015 at 18:02

2 Answers 2


Some software is just like this.

Fortunately, you indicated that you're using Windows 7, and Windows 7 has a way to handle such software. Windows 7 has a startup method called "Automatic (Delayed Start)". That may be more appropriate for a service that works fine in many cases, but doesn't work fine right when the system starts if "Automatic" is used as the startup type. To do this, go to the Services MMC applet (accessible from within Computer management), find the service, right click on it, and choose "Properties". Then change the startup type. The SC command can allow this to be done from the command line, using "delayed-auto".

The administrator (presumably: you) should check the operating system logs that are called "System" and "Application". See if they have any details that are related to the service starting or stopping.

If you don't like manually running a batch file, then you might want to have this occur when a user logs in. Task Scheduler might have some helpful options.

I'm in agreement with several of the other information that people have added to this page. Be sure to review them too.

  • I finally got around to playing with it and delayed startup fixed the issue.
    – pooter03
    Feb 3, 2015 at 13:41

It is possible that service receives start command but fails to complete its startup procedure.

It is also possible that it starts as intended but stops immediately afterwards.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .