2

So I've lived with this problem for several weeks now, hoping that if I just let it happen enough, I would figure out the underlying trigger. No luck.

tmux in bash in gnome-terminal in XMonad on Ubuntu 14.04.1 LTS (clean install). same bug in when instead of XMonad I use vanilla Unity (even clean installed).

It seems that every now and then something is printing the character u'0x001b', superimposed over a ']' character in the string "]112" instead of recognizing this as escape followed by some numbers, tmux prints it verbatim to a (random) position on the screen. Recently, the string "]112" has also started to appear without the unicode character very occasionally. It appears that if the characters go off the end of a vim line, replacing the first one can sometimes leave the others intact.

Anything that forces a redraw of the rectangle holding the unicode character gets rid of the whole sequence of them. In Vim, I can delete each individual character in the string "]112" as if it was actually there, however. Simply changinging their colors, e.g. by positioning the cursor over them in vim, does not get rid of them.

I don't have enough reputation to post images, but I'll host a little screencast of what the problem looks like at: http://www.brunobeltran.com/junkdump/tmux_error.mkv

Below is my .tmux.conf. I have played with various values for the escape-time, to no avail. Also, removing mouse stuff does not help.

Any idea or things to try would be greatly appreciated!


# 0 is too far from 1
set -g base-index 1

# Automatically set window title
set-window-option -g automatic-rename on
set-option -g set-titles on

set -g default-terminal screen-256color
set -g status-keys vi
set -g history-limit 10000

setw -g mode-keys vi
setw -g mode-mouse on
setw -g mouse-resize-pane on
setw -g mouse-select-pane on
setw -g mouse-select-window on
setw -g monitor-activity on

bind-key v split-window -h
bind-key s split-window -v
bind-key J resize-pane -D 5
bind-key K resize-pane -U 5
bind-key H resize-pane -L 5
bind-key L resize-pane -R 5
bind-key M-j resize-pane -D
bind-key M-k resize-pane -U
bind-key M-h resize-pane -L
bind-key M-l resize-pane -R

# Vim style pane selection
bind h select-pane -L
bind j select-pane -D
bind k select-pane -U
bind l select-pane -R

# Use Alt-vim keys without prefix key to switch panes
bind -n M-h select-pane -L
bind -n M-j select-pane -D
bind -n M-k select-pane -U
bind -n M-l select-pane -R

# Use Alt-arrow keys without prefix key to switch panes
bind -n M-Left select-pane -L
bind -n M-Right select-pane -R
bind -n M-Up select-pane -U
bind -n M-Down select-pane -D

# Shift arrow to switch windows
bind -n S-Left  previous-window
bind -n S-Right next-window

# No delay for escape key press
set -sg escape-time 0

# copy to clipboard in sane way on linux with xclip
bind -t vi-copy y copy-pipe 'xclip -in -selection clipboard'

# Reload tmux config
bind r source-file ~/.tmux.conf

# THEME
set -g status-bg black
set -g status-fg white
set -g window-status-current-bg white
set -g window-status-current-fg black
set -g window-status-current-attr bold
set -g status-interval 60
set -g status-left-length 30
set -g status-left '#[fg=green](#S) #(whoami)'
set -g status-right '#[fg=yellow]#(cut -d " " -f 1-3 /proc/loadavg)#[default] #[fg=white]%H:%M#[default]'

## my additions start here
# fix pgup/pgdn issues
#set -ga terminal-overrides ',xterm*:smcup@:rmcup@'
# Set up workflow for CJW Lab
#
new  -n Shell  "/usr/bin/env bash"
splitw -h -p 50 -t 0 "bash"
neww -n Matlab "/opt/MATLAB/R2014b/bin/matlab -nodesktop -nosplash"
splitw -h -p 50 -t 0 "bash"
neww -n Mathematica  "/opt/Wolfram/Mathematica/10.0/Executables/math"
splitw -h -p 50 -t 0 "bash"
neww -n Asciiquarium "~/bin/asciiquarium"
neww -n Media  "/usr/bin/ncmpcpp"

# Fix my leader to be Ctrl-q
unbind-key C-b
set -g prefix 'C-q'
bind-key 'C-q' send-prefix

  • I'm seeing the same issue! Did you ever figure it out? – Jeff Mar 21 '15 at 23:47
  • to date I haven't figured it out (latest install of Ubuntu, all updates, latest tmux from repo). What's your setup? Maybe if both of us go submit a bug report someone will listen? I can't figure out where the correct place to submit a bug on this topic would even be. – brunobeltran0 Mar 23 '15 at 2:21
  • I'm running Crunchbang (Debian with terminator for my terminal). Are you doing any remote ssh sessions and re-attaching to tmux sessions? I also use Cygwin/Mintty to ssh and attach to my tmux sessions and do not see this behavior from those sessions, which makes me think it has something to do with the terminal rather than tmux. – Jeff Mar 23 '15 at 5:06
  • One other thing, I never noticed this until I recently switched to using the Solarized color scheme. – Jeff Mar 23 '15 at 5:13
  • 1
    Also switching away from Solarized does not help, so I would like to think it is indeed a terminal-specific problem. Jeff, can you mark this bug as also affecting you? bugs.launchpad.net/ubuntu/+source/gnome-terminal/+bug/1435905 – brunobeltran0 Mar 24 '15 at 14:43
2

Per Egmont Koblinger's helpful input on the bugtracker (https://bugs.launchpad.net/ubuntu/+source/gnome-terminal/+bug/1435905), it appears that this bug has been fixed upstream.

The bug appears to have been caused by libvte's lack of support for OSC 112, the "reset cursor color" escape character. This is probably why Jeff noticed the bug after installing solarized. Both terminator and gnome-terminal use libvte, so the same fix should apply to both.

Simply install the latest version of libvte (libvte-2.90-9/utopic) from the utopic repos by adding the lines

deb http://us.archive.ubuntu.com/ubuntu utopic main restricted

deb http://extras.ubuntu.com/ubuntu utopic main

to the file

/etc/apt/sources.list

(requires root priveledges).

Then request that apt install only libvte-2.90-9 from the utopic repos by performing a

~# apt-get update

followed by

~# apt-get install libvte-2.90-9/utopic

This should fix the problem in Ubuntu Trusty. Older versions of Ubuntu might struggle with dependency problems, it's hard to know.

0

This is also reported over on github. Putting the following line in your .tmux.conf file solves the issue until libvte is updated.

set-option -g terminal-overrides ',xterm*:Cr=\E]12;gray\007'

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.