in my home computer incoming port 80 was blocked. i gess it was done by some vires. did any body know how to open the closed port in xp. or any tool to open colosed ports.

  • Are you sure you're actually running a server that listens to that port? Or: are you sure this is about incoming connections (from the internet to your computer), and not about outgoing connections (from your computer to the internet)? – Arjan Dec 22 '09 at 12:22
  • If you cannot surf the web because port 80 is blocked, it is 99% likely the problem is your computer's firewall. If you cannot run a web server program on your computer, it could be any number of things- again, the firewall, anti-malware, or another web server already running. – kmarsh Dec 22 '09 at 13:37

How are you testing that 80 is blocked? A lot of ISP's block port 80 to stop people running webservers on consumer accounts.

  • gorilla thanks for reply. but my problem is my incoming port 80 bolocked. not the out going port 80. – Kombuwa Dec 22 '09 at 12:22
  • 3
    Kombuwa, "Incoming" usually means connections from the Internet to your computer, like people accessing a web server running on your computer. "Outgoing" means connections from your computer to the Internet, like surfing the web or downloading a file -- so gorilla is talking about incoming port 80. – Nick Meyer Dec 22 '09 at 14:44

If its your windows firewall thats infact blocking it you can open the port by:

Start -> Run

Enter this: netsh firewall set portopening tcp 80 ENABLE

Press OK.

(If my memory doesn't serve me wrong)

EDIT: You need administrator rights to perform this

  • i artifex i have checked your way. it shows theris nothing problem in my laptop (no port blocking, no vires). because of it i have bring the my lap to connect in my office network it was perfectly working. now i gess problem in my adsl-router – Kombuwa Dec 28 '09 at 7:59

What does netstat -a tell you?

If you're using Windows, try:

netstat -a | findstr :80

...or try Sysinternals' TCPView

Maybe there's something already running which is listening on that port.

Or do you have some firewall software which is butting in and blocking it?

  • If there is something already listening on port 80 which you weren't expecting it's probably Skype. Skype grabs ports 80 and 443 unless you tell it not to. – Dave Webb Dec 22 '09 at 15:37

Have you installed any anti virus software recently? That can cause problems with ports. And have you tried system restore?

  • i didnt install any. ill try the your second option. – Kombuwa Dec 22 '09 at 12:23

You mention that at home, where things don't work, you have an ADSL router.

Where are these incoming connections coming from? Are you testing incoming connections from another machine on your local network, or from machines in the internet?

At work, where you say things work, are you testing incoming connections from another machine on your local network, or from machines in the internet?

If you are trying to test incoming connections to your laptop from the internet when you're at home, and you have a router, does your router port-forward port 80 from it to your laptop?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.