1

I want to install a Synaptics touchpad driver on my Lenovo G710 laptop.

I downloaded a new touchpad driver from the Lenovo support website. It said it was for Synaptics, Elan, Alps. I clicked to install, and it looked like it was going to install Synaptics, which is what I want; but the text was cut off so I wasn't sure. No choice was made available. When I continued, I got a box saying that ELAN was being installed.

I've checked around on this site, especially the suggested questions that appeared as I typed this question, and tried going to the device manager and picking a driver to update. The choices there are Lenovo and PS/2.

  • Could you provide specific device details about the touchpad itself? I am trying to determine what type of touchpad you have exactly. I am specifically looking for A device identification information from Device Manger. – Ramhound Jan 15 '15 at 20:51
  • Does this help? ELAN, 7/31/2013, VERSION 11.4.25.1 Device ACPI\ETD060E\4&2fbd9b47&0 – Roger F. Gay Jan 16 '15 at 8:32
  • You have an Elan touchpad device. Synaptics device driver isn't going to work with it based on the deviceid. – Ramhound Jan 16 '15 at 11:09
  • Thanks. What about the PS/2? It's one of the options I get when I browse the Lenovo Pointing Device update via device driver. – Roger F. Gay Jan 16 '15 at 13:57
  • It isn't really relevant to your case. The Synaptics driers are not for the particular device model you have. – Ramhound Jan 16 '15 at 16:27
0

This was my situation with Lenovo Edge Windows 10 Synaptics driver. See whether this helps. I was using Windows 10 in my Lenovo Edge 15. It happened suddenly. Double finger touch wasnt working. So I've uninstalled Syaptics driver and tried reinstalling the driver which I've downloaded from Lenovo/Synaptics website. After installation, it errored "Synaptic device not found".

With this state, just go to Device Manager under Control Panel.
Under Mice and other pointing devices, right click Lenovo Pointing Devices > Update Driver Software...

Finish it and restart the machine. This should work.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.